Download media-7.x-2.8.tar.gztar.gz 139.87 KB
MD5: 718b9345bf1ae8c0ffdf246668c61bff
SHA-1: fdfcbe461ccb687b59b02801d2324531b35b040b
SHA-256: 05ca8c112ec296136becaee1551e79ac3a0216f14ce622760ad13e539475511b
Download media-7.x-2.8.zipzip 187.85 KB
MD5: 322e8176eeab846561c4363b9bd474dc
SHA-1: 4d6640cea2815e3875a9f251164c5392c49d5e15
SHA-256: 42cf983c42810096bf5fcce396138de8d1597917c2a948ee9ad400df252f11f9
Install with Composer: $ composer require 'drupal/media:^2.8'
Using Composer to manage Drupal site dependencies

Release info

Created by: joseph.olstad
Created on: 16 Jun 2017 at 07:17 UTC
Last updated: 4 Jul 2017 at 13:24 UTC
Core compatibility: 7.x
Release type: Bug fixes

Release notes

To use this release it is recommended to also upgrade file_entity to 7.x-2.2. This is release 7.x-2.8 of media 7.x-2.x branch, improved support for upgrades from 7.x-1.x to 7.x-2.8 (please read the full release notes). These are the following issues resolved since 7.x-2.7:
#2886610: Typo for $host->$language
4 Fixes since 7.x-2.6
#2886184: Fix media_wysiwyg.paragraph_fix_filter tests, which are failing in PHP 5.3
#2884412: add the config option for add embed link to make it optional
#2885024: Notice: Undefined property: ParagraphsItemEntity::$language in media_field_widget_form() (
and:
enforce require file_entity 7.x-2.1 or higher

Quick install , follow this recipe steps or see online installation documentation

If you are on 7.x-2.x already and plan on delaying upgrading to 7.x-2.8 then please follow the security recommendations below:
Prevent anonymous or untrusted users from accessing the media browser through permissions configuration.
go to /admin/people/permissions and restrict access to "Use the media browser" to only trusted roles. Otherwise it is recommended you upgrade to 2.8 as soon as possible.

If on 7.x-1.x , please upgrade to 7.x-2.7 soon, please refer to these notes and issues for upgrading from 7.x-1.x to 7.x-2.8;
#2853273: upgrading from 1.x to 2.x support
#2082037: Document Upgrade Path from Media 1.x to Media 2.x/3.x

Multilingual sites:
Please note, if you are using this release in combination with entity_translation you must then upgrade entity_translation to entity_translation beta6.

Dependencies

The selected release is the release that will be used for automated testing. Optional projects are only used for testing.

Required

Optional