I'm receiving a "Uncaught TypeError: Cannot read property of undefined" error message on line 27 of fckeditor.utils.js. Looking into it a little, fckeditor.util.js calls the property "Drupal.settings.fckeditor.settings[taid]" multiple times, which isn't set... Anyone else having this issue? This started after I updated from 2.3 to 2.4 (security update).

#1 typeerror-2389569-1.patch1.75 KBrobdubparker
Members fund testing for the Drupal project. Drupal Association Learn more


robdubparker’s picture

1.75 KB

Here is a patch that seems to fix the issue for me

joostvdl’s picture

Patched solved my problem too.

joostvdl’s picture

Status: Active » Needs review
ZoeN’s picture

Patch solved the same problem for me too.

candelas’s picture

Patch solved the same problem for me too. Thanks @robdubparker

candelas’s picture

Status: Needs review » Reviewed & tested by the community
e5sego’s picture

Patch works for me.

apetro’s picture

Patch #1 works for me also. Thanks!
This bug was very problematic for me: after updating browsers, I could not open collapsed menu in node edit!
Is it possibile to include this patch in module stable version?