Just updated Firefox to the newest version, 15.0. Now I can't post comments from FCKeditor enabled fields, they are passed as empty and trigger "The field comment is required" error.

"Switch to simple text entry" is also missing. Other parts of editor do load (all the formatting buttons etc).

Firefox error console says:
Error: NotFoundError: Node was not found
Source File: http://www.mysite.com/sites/all/modules/fckeditor/fckeditor/editor/js/fc...
Line: 31

Updated to the newest release of FCKEditor (2.6.8) without any improvement.

Using Drupal 6.25.

#35 fck_editor_firefox.patch47.92 KBgpk
#24 patch.tar.gz68.3 KBBrn
Members fund testing for the Drupal project. Drupal Association Learn more


Jorrit’s picture

Please update to CKEditor (http://drupal.org/project/ckeditor). FCKeditor is very old and wasn't developed with these newer Firefox versions in mind. I think the latest version of Firefox at the time FCKeditor was last updated was 3.x or even lower.

sniegs’s picture

Can't agree on the age:
FCKeditor (drupal module) last update: 2012-Mar-14
FCKeditor (the editor itself) 2.6.8, released on 2 August 2012

Jorrit’s picture

Since 2010, the releases of the editor and the module only contain security fixes. Nothing was done in terms of browser support.

bianca@blast.com.au’s picture

The same issue is happening for me. Content values are not saved at all for my Drupal apps using FCKEditor and Firefox 15.0. This is a HUGE problem!

ramkumarr’s picture

After upgrading to firefox 15, me too facing the same issue.

squinternata’s picture

i have the same problem once we updated to firefox 15.0, but i have different sites .and in one of this it works well also with fckeditor 6.2.1...

sniegs’s picture

I posted a bug report on FCKEditor / CKEditor site. Although FCKEditor is unsupported, I hope they manage to correct the problem if it's just a matter of couple of changes in Javascript for Firefox. At worst I will have to upgrade to CKEditor or Wysiwyg but really don't want to touch the fragile integration of Editor + Image Browser and other modules I managed to get working, it will be a major waste of time…

izmeez’s picture

I can also confirm that Firefox 15.1 and 16-beta-1 causes problems with the fckeditor. On new posts it does not save the body content only the title. With all the rapid changes Firefox has introduced recently it makes me wonder if the problem is related to the browser updates, but no way to be sure at the moment.

kamasplice’s picture

Having the same problem as #8 using FCKEditor 6.x-1.4 and Firefox 15.0. The body disappears when saving a node, and does not reappear upon editing again.

sniegs’s picture

My bug report at CKsource was rejected for FCKEditor being unsupported (as Jorrit suggested). So it's either upgrade to CKEditor / Wysiwyg, or hope somebody can correct fckeditor javascript source on line 31. Or hope Firefox people will correct this error in their later betas of 16… Not likely.

izmeez’s picture

Is this because fckeditor uses combination of javascript and cold fusion and ckeditor is only javascript?
If so the time to switch may have arrived ...

florisla’s picture

Status: Active » Closed (won't fix)

I experienced this "field comment is required" bug on Firefox >= 15.0 also.

Switching to Wysiwyg with the latest CKEditor went reasonably smooth, even with file browser / upload support (IMCE, IMCE Mkdir) so it's definitely recommended.

florisla’s picture

I guess this ticket can be closed since it's an FCKEditor problem (i.e. in the external project, not in the Drupal fckeditor.module) and it is quite clear that FCKeditor will never fix this; see e.g. http://dev.ckeditor.com/ticket/9296 .

izmeez’s picture

Yes, I agree. Like so many things when you get to it you wonder why you didn't do it sooner.
Thanks very much to the developers of the ckeditor module.
I did find a specific issue with the upgrade and I will post that in the ckeditor queue where it belongs.

fan777’s picture

FCKeditor -> Default (<- for example) -> Cleanup and output ->Enter mode: -> Set to "<\br>". It solved the problem for me. The Default value of this field is set to "<\ p>" and FCKeditor cuts a comment.

cjohn112’s picture

fix #15 fixed it for us, too. thank you!

Gergely Varga’s picture

Just to encourage everybody to update, I would like to say that it is very simple to update to CKeditor. It will even automatically import the old FCKeditor settings. Don't forget to follow the Setup Instructions. Time required: 30mins. :) Good luck!

fishclic’s picture

Thanks fan777 !!

Your fix worked ... and it's fast and easy to apply ! ;)

izmeez’s picture

Do you have fckeditor working with android and iOS mobiles? This may be another reason to make the switch to ckeditor. The upgrade is surprisingly easy. The biggest problem was understanding how to configure the spell checker and I'm just about to post on that issue.

alb’s picture

but ckeditor is a really free license? I remember time ago only partially; is free only for site tahta aren't for commercial use;

which are the problem regards fckeditor working with android and iOS mobiles?

how you found this solution?

izmeez’s picture

@alb We had some problems with fckeditor and mobile devices awhile ago on a project. Sorry I don't have details. Does it work ok for you on mobile devices?

toddgee’s picture

Found this post from here: http://drupal.org/node/1780760
Cross-posting my experience there and here.

I tried the #15 fix and it worked.
I changed the enter mode and it started working again. Then, I changed it back and it kept working.
It looks like the fix happens when you make an update to the configuration.

taite11’s picture

#15 worked for me too.

Some people suggested that everybody should upgrade to CKEditor. That should work in theory...but there are a couple problems with that. For one, upgrading to CKEditor didn't work for me - CKEditor won't even show up on my website. For another thing, FCKEditor has a nice built-in file browser. I'm sure there are other advantages for FCKEditor as well, so switching to CKEditor isn't a solution for everybody.

Brn’s picture

Status: Closed (won't fix) » Active
Issue tags: +fckeditor
68.3 KB

Patch for the module fckeditor-6.x-2.1 and editor FCKeditor 2.6.8 to work with the recent versions of Firefox (Firefox 17.0)

Not enough to fix bug for fckeditor-6.x-2.3 ...

Summit’s picture

Hi, isn't fckeditor-6.x-2.1 havng security issues?
greetings, Martijn

Alastairo’s picture

I found this fix on the mozilla forum :
To fix this problem, simply edit the following:

/fckeditor/fckeditor_php5.php (go to line 58) and change it from:

return ($iVersion >= 20030210) ;


return TRUE ;

Have fun,


Worked like a dream for firefox 17

tryitonce’s picture

Thanks to comment #15 I solved my problem as well. Thanks!!!!!!!

Just in case someone finds the problem I had and runs around the block like I did quite confused - here is what I found:

  • Drupal 6 installation with latest FCKeditor - all properly installed.
  • Firefox 17.0.1 - did not have this problem previously - and don't believe it is a Firefox / browser problem at all.
  • Suddenly the Content Type "Forum" would not save the Body Text on fresh notes any more with FCKeditor.
  • FCKeditor turned off no problem with Content Type "Forum".
  • Editing & saving existing nodes of the Content Type "Forum" was not a problem with FCKeditor on.
  • All other Content Types did not have this problem and saved the Body Text fine with FCKeditor on.

So, I tried all sorts of remedies including CKeditor upgrade which I am using on some D7 sites without a problem. But CKeditor just would not show up on any of the Content Types. So, I went back to FCKeditor and this thread with #15 solved the issue for now.

>>> Stop reading here - the rest is more likely for another website!!!! <<<
Upgrading - yes, well - this is the crux with software - who uses more than 10% of an office package - any for that matter. Okay, say, who uses more than 38.9%?
Even at that very advanced level, 60% of the offices packages will remain a mystery to most likely 80% of users.
That makes very bad efficiency.
We all need to

  • change our thinking and stop tinkering too much with these machines, code and endless upgrades. Firefox being one of the worst coming out with new versions once a month it seems at times.
  • keep things simple and efficient.
  • go more out and tend the garden and / or just for a walk.
  • make sure the world changes to become a better place.
  • understand that the earth will do nicely without our species and
  • the "world" we talk about too often is the one we see and make, i.e. "world" = humans - nothing to do with the Earth.

Not funny?? I told you not to read on ....
Some sympathy?? - See you shortly on the beach for a run or swim or around the garden, great tomatos turning red ...

tryitonce’s picture

Just one note in respect of comment #15 -
In my case I had to change the default setting

in ..../admin/settings/fckeditor/edit/Advanced" Cleanup and output" under "Enter mode:".

Djak’s picture

I did a quick (n'dirty ?) fix for this, cause no time for updating to CKEditor for now.
Problem is uncaught exception thrown by removeChild() call in FixBody:function() in fckeditorcode_gecko.js line 31

// Original code :
// Fix
try {E.appendChild(H.removeChild(D));}catch (NotFoundError) {;}finally {D=E.nextSibling;}

Works with 6.x-2.3 and FF 17.0.1 (desktop, dunno for mobiles) and seems to break nothing else... (and keep 'p' for enter mode)
Don't forget to configure browser cache to reload newer pages after updating js file.

Boobaa’s picture

Ran into the same issue; #15 worked for me; #22 didn't work, #26 didn't work; #29 didn't work. Using FCKeditor-2.6.9 (latest) with fckeditor.module-6.x-2.3 (latest) and Firefox-19.0 (latest). OTOH, it works only for submitting new content; when I try to edit existing content the FCKeditor fields are defaulting to empty.

gpk’s picture

Initial testing of #29 is looking good for me. This is using module version 6.x-2.3 with FCKeditor 2.6.10 (of 21 March 2013) and Firefox 21.0.

The file fckeditorcode_gecko that needs changing will normally be in this folder under the Drupal root:

It is a compressed JS file so you will need to use your text editor to search for E.appendChild(H.removeChild(D));D=E.nextSibling; and replace it with try {E.appendChild(H.removeChild(D));}catch (NotFoundError) {;}finally {D=E.nextSibling;}

You should end up with two RH curly brackets }} at the end of your modifications (one that was already there and a new one).

Then Clear Cached Web Content (Preferences --> Advanced --> Network and press the Clear Now button).

The symptom I was seeing was that when creating a new node or adding a new comment using Firefox then the content was erased somehow during or after form Submit. Editing existing content seemed to be OK. I wonder how many would be commenters on our website have been seeing their well-crafted prose vaporised before their eyes.

Merci à Djak!

gpk’s picture

Title: Can't post comments with Firefox 15.0 » Can't post comments with Firefox 15.0+

[update title]

gpk’s picture

Title: Can't post comments with Firefox 15.0+ » Can't post new content (comments, nodes) with Firefox 15.0+


gpk’s picture

47.92 KB

Here's a patch based on #19 for anyone out there who might want to use it. I'm not changing the status of this issue since the patch is a fix for the editor code rather than for the Drupal module. It's based on the FCKeditor 2.6.10 download. You will need to run it from the .....fckeditor/fckeditor folder, which is normally sites/all/modules/fckeditor/fckeditor, with a command such as the following:
patch -p1 < fck_editor_firefox.patch
(assuming you copied the patch file to that folder).

It seems that IE 10 also fails with FCKeditor... more on that later!