I've updated my local dev environment's Drupal install via composer and apparently it installed correctly.

Now whenever I hit the page or while using drush I get the following error:

PHP Fatal error: Interface 'Symfony\\Cmf\\Component\\Routing\\ChainedRouterInterface' not found in /vagrant/www/vendor/symfony-cmf/routing/DynamicRouter.php on line 39

I used composer with the --no-dev option due to a drupal/coder dependency that was breaking the install. Could this be the reason for my Drupal install being broken?

Can anyone share any insight? I'm lost in a chicken/egg situation and don't know it is a symfony dependency issue or a drupal/coder dependency issue.

CommentFileSizeAuthor
#5 composer.json_.txt4.09 KBjoum
Members fund testing for the Drupal project. Drupal Association Learn more

Comments

joum created an issue. See original summary.

cilefen’s picture

What version of Symfony installed?

joum’s picture

This is what composer installed:

stecman/symfony-console-completion    0.7.0
symfony-cmf/routing                   1.4.1
symfony/cache                         v3.3.10
symfony/class-loader                  v3.2.13
symfony/config                        v3.2.13
symfony/console                       v3.2.13
symfony/css-selector                  v3.3.10
symfony/debug                         v3.3.10
symfony/dependency-injection          v3.2.13
symfony/dom-crawler                   v3.3.10
symfony/event-dispatcher              v3.2.13
symfony/expression-language           v3.3.10
symfony/filesystem                    v3.3.10
symfony/finder                        v3.3.10
symfony/http-foundation               v3.2.13
symfony/http-kernel                   v3.2.13
symfony/polyfill-apcu                 v1.6.0
symfony/polyfill-iconv                v1.6.0
symfony/polyfill-mbstring             v1.6.0
symfony/process                       v3.2.13
symfony/psr-http-message-bridge       v1.0.0
symfony/routing                       v3.2.13
symfony/serializer                    v3.2.13
symfony/translation                   v3.2.13
symfony/validator                     v3.2.13
symfony/var-dumper                    v3.3.10
symfony/yaml                          v3.2.13
joum’s picture

I tried clearing vendor, core and modules/contrib folder; deleted the composer.lock file and cleared composer's cache.

Again, the composer install step goes all the way through, but every time I try to access the site it throws the above PHP error.

drush status output:

Password for user root:
 Drupal version : 8.4.2
 Site URI       : http://default
 DB driver      : pgsql
 DB hostname    : localhost
 DB port        : 5432
 DB username    : ********************
 DB name        : ********************
 PHP binary     : /usr/bin/php7.0
 PHP config     : /etc/php/7.0/cli/php.ini
 PHP OS         : Linux
 Drush script   : /vagrant/www/vendor/drush/drush/drush
 Drush version  : 9.0.0-beta3
 Drush temp     : /tmp
 Drush configs  :
 Drush aliases  :
 Drupal root    : /vagrant/www/
 Site path      : sites/default
joum’s picture

FileSize
4.09 KB

Also, in case it helps, the composer.json file (in txt format).

joum’s picture

Also updated composer to (I think) latest version:

Composer version 1.5.2 2017-09-11 16:59:25

Still the same error.

How can composer install all the way through without failing and then Drupal throw an error due to a dependency of drupal/core?

Also tried reverting to 8.3.7 and it still throws the same error.

I'm baffled by this.

cilefen’s picture

Issue tags: +composer

You have got mixed versions of Symfony components installed and FWIW Drupal 8.4.x core is locked on 3.2.8.

joum’s picture

@cilefen can you elaborate? How can I fix this?

tim.plunkett’s picture

Neither ChainedRouterInterface nor DynamicRouter have been used in core since before 8.3.0 (over a year ago).
Additionally, they are from the same project. No idea how you'd have one without the other.

eveyrat’s picture

@joum Same problem here.

Looks like a problem with composer as i also have a problem with drush (installed through composer), being partially downloaded.

eveyrat’s picture

Update : Problem appears after upgrading to Mac OS High Sierra.
Fixed upgrading Mac Os High Sierra 10.13.2 Developer beta.

See here for more information : https://github.com/hashicorp/vagrant/issues/8788

hsponner’s picture

Thanks @eveyrat, it fixed the issue for me, too.