I'm getting the following error message from upgrade/migrate.

"file_rendered" plugin does not exist. (C:\UwAmp\www\D8\core\lib\Drupal\Component\Plugin\Discovery\DiscoveryTrait.php:52)

What does this mean? Do I need to be worried about it?

I am using Windows 10 with UwAmp 3.1.0, PHP 5.6.18, and MySQL 5.7.11.

Thanks!

Comments

samstamport created an issue. See original summary.

mikeryan’s picture

Status: Active » Postponed (maintainer needs more info)

Where exactly in the migration process does that occur (what migration was running at the time)? If you were using the UI, the watchdog (at /admin/reports/dblog) should show you when it happened relative to the migrations being run.

Were you upgrading from Drupal 6 or from Drupal 7?

Does "file_rendered" appear anywhere in your D8 contrib/custom modules, or in your D6/D7 code? Does it appear in your source database (dump the database to a .sql file and grep for it)?

samstamport’s picture

It looks like the process before this was "Upgraded View modes (processed 29 items total)". The step that follows these error messages is "Upgraded Field instance widget configuration (processed…".

I'm upgrading from D7.

Inside htdocs\profiles\openoutreach\modules\contrib\file_entity\views is a file named views_handler_field_file_rendered.inc. It is part of the Open Outreach Distribution. Since I will have to manage my D8 migration without Open Outreach because it has not been ported to D8 maybe I can ignore these messages?

A search of the database reveals the following tables that reference "file_rendered".

System
registry_file
registry
field_config_instance

samstamport’s picture

Status: Postponed (maintainer needs more info) » Active
heddn’s picture

Version: 8.1.8 » 8.6.x-dev
Status: Active » Postponed (maintainer needs more info)

Can this be reproduced on 8.6?