Firebug for Drupal themeing. See the screenshot and screencast. Note that this module injects markers into the DOM to do its magic. This may cause some themes to behave erratically and less capable browsers may make it worse (especially IE)/. Enable it when needed, and disable it afterwards.

This module was part of the Devel project. Now it is its own project, but relies on the Devel and simplehtmldom API modules as dependencies.

Currently, Theme Developer does not work with the latest version of
simplehtmldom API. You must use simplehtml API version 7.x-1.12 if you want Theme Developer to function properly.

Project Information