Accessibility Checker for CKEditor

Introduction

This module enables the Accessibility Checker plugin from CKEditor.com in your WYSIWYG. This plugin is an innovative solution that lets you inspect the accessibility level of content created in CKEditor and immediately solve any accessibility issues that are found.

Requirements

  1. CKEditor Module (Core)
  2. CKEditor Balloon Panel module.

Installation

  1. Download the plugin from http://ckeditor.com/addon/a11ychecker.
  2. Place the plugin in the root libraries folder (/libraries).
  3. Enable CKEditor Accessibility Checker in the Drupal admin.
  4. Configure your WYSIWYG toolbar to include the button.

This project only handles the bridge between Accessibility Checker and Drupal. For support to the Accessibility Checker library feel free to ask at their project page.

Important

The Accessibility Checker plug-in is planned to be added to Drupal Core. See #2731373: [upstream] Include CKEditor's Accessibility Checker plug-in for details. Once that is done, and the plugin is included in a stable core release, this module will no longer be needed.

Supporting organizations: 
Initial development and maintenance
Maintenance

Project information

Downloads