I received this in the process of upgrading from 5.x to 6.x, following directions implementing step by step... everything seemed to work fine.

I installed some updates to unrelated modules and get this error when trying to access the modules page.

I was using the CCK 2.x dev version to allow for multigroups (jul-10 version) and have also tried CCK 2.x dev (aug-10) with the same result. Went to stable version with the same result.



bsnodgrass’s picture

I've also had this trouble, could it be related? The message below during update indicates the content.module is not enabled? (it was enabled when I was last able to access the modules screen)

The following queries were executed
date module
Update #6005

* Failed: date.module has updates but cannot be updated because content.module is not enabled.
If and when content.module is enabled, you will need to re-run the update script. You will continue to see this message until the module is enabled and updates are run.

markus_petrux’s picture

Category: bug » support
Priority: Critical » Normal
Status: Active » Fixed

Please, review the instructions to upgrade from D5 to D6 in the CCK project page. It seems you forgot to disable the fieldgroup module. This module requires CCK, so it is not possible to enable this if CCK is not enabled first. This is a manual operation error while doing the upgrade.

bsnodgrass’s picture

No I had done that and according to the modules page CCK was enabled prior to that... The site has been up and running for a week with numerous updates to module occuring since then.

I believe this update message is in error.

markus_petrux’s picture

Content module is NOT enabled for some reason while Fieldgroup module is enabled. This is wrong.

Fieldgroup is enabled and complains because it cannot find function content_types(), which is implemented by Content module. It cannot find this function because Content module is not loaded, and it is not loaded because it is not enabled, or there are missing files, or something else which is wrong in your installation.

bsnodgrass’s picture

Thanks.. I stepped back to an old backup and built from there using module files from another install. Not sure what was wrong, but I am working again.

Perhaps I had some old files in the modules directory... I remember early in the process I removed some which were in the sites/all/modules folder that should have been in module folders. Could that have been an issue?

markus_petrux’s picture


If content module was removed, but fieldgroup module wasn't, then Drupal could have loaded fieldgroup, but not content module, and that explains the first error reported, which is the cause that also date updates failed, etc.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

jfinkel’s picture

Version: 6.x-2.5 » 6.x-2.8
Status: Closed (fixed) » Needs review

I just got this same error after updating from cck 6.x-2.7 to cck 6.x-2.8. It took me an hour to uninstall all the CCK stuff and flush the caches (via a MySql UI) and then reinstall CCK.

JennyGB’s picture

Issue summary: View changes

"It took me an hour to uninstall all the CCK stuff and flush the caches (via a MySql UI) and then reinstall CCK."

you mean that you deleted all the cck folders (in sites/all/modules) + cck tables, then erase all data in cache tables ? but my site is using nodereference and cck