I've installed 7.x-3.19 into a site that was running quite happily with 3.18. But when I (try to) run update.php, I get thrown to my site's home page. There are no entries in the site log (admin/reports/dblog) or the apache log, and no drupal_set_message-type messages. I've tried changing the site's theme to Bartik while doing update.php, but with no effect.

Any advice? I'm comfortable with hacking around in module and site source, so if I can do anything to track down the problem at this end, please let me know.

Comments

jim_at_miramontes created an issue. See original summary.

jim_at_miramontes’s picture

Issue summary: View changes
jim_at_miramontes’s picture

Issue summary: View changes
jim_at_miramontes’s picture

Sorry for the versioning confusion. Upshot: my site is working fine with 3.17 and 3.18, but can't update to 3.19 (when trying to update from 3.18).

A bit of crude debugging indicates that it properly (successfully, anyway) makes its way through the update.php code, but when it goes off to theme up the update_page, something goes sideways in the theme_update code and it decides to throw to my home page.

markcarver’s picture

Category: Bug report » Support request
Status: Active » Closed (cannot reproduce)

I've tried changing the site's theme to Bartik while doing update.php, but with no effect.

Then this alone should tell you it's not a theme problem, nor an issue with this project.

jim_at_miramontes’s picture

Category: Support request » Bug report
Status: Closed (cannot reproduce) » Active

Hmm. Sadly, I see the point. If I come up with any relevant insights, I'll re-post. Thx.

markcarver’s picture

Category: Bug report » Support request
Status: Active » Closed (cannot reproduce)