Since I have upgraded bootstrap 3.15 to 3.16 my site is causing lots of errors in views.

Notice: Undefined index: attributes in context_preprocess_menu_link() (Zeile 247 von sites/all/modules/context/context.module).
Warning: in_array() expects parameter 2 to be array, null given in context_preprocess_menu_link() (Zeile 247 von sites/all/modules/context/context.module).

As a quick workaround I downgraded page.vars.php to bootstrap 3.15 and the errors are gone. The errors point to context, but seems caused by a change in bootstrap.

CommentFileSizeAuthor
#7 2934821-7.patch1.34 KBmarkcarver
Members fund testing for the Drupal project. Drupal Association Learn more

Comments

hass created an issue. See original summary.

hass’s picture

Project: Addressfield Tokens » Context
Version: 7.x-1.7 » 7.x-3.x-dev
hass’s picture

Project: Context » Bootstrap
Version: 7.x-3.x-dev » 7.x-3.16

Rolled back the changes in page.vars.php made in 3.16 and the issue disapeared with the file from 3.15.

hass’s picture

Issue summary: View changes
markcarver’s picture

Title: Undefined index: attributes / in_array() expects parameter 2 to be array, null given » Regression: i18n menu tree changes
Version: 7.x-3.16 » 7.x-3.x-dev

Turns out that the patch provided used menu_tree_all_data, not menu_tree_page_data, which is what menu_tree uses (the code that got replaced).

markcarver’s picture

Title: Regression: i18n menu tree changes » [REGRESSION] Menus break because all menu items are loaded

Better title

markcarver’s picture

Status: Active » Fixed
FileSize
1.34 KB

  • markcarver committed bb43013 on 7.x-3.x
    Issue #2934821 by markcarver: [REGRESSION] Menus break because all menu...

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.