Blocks that are set to 'disabled' status via: Block Layout are still rendered when using a subtheme. They are removed from display as expected if you switch to use Bootstrap (primary) theme as default.

Comments

Korben_Dallas created an issue. See original summary.

markcarver’s picture

Status: Active » Closed (works as designed)

Clear cache

Korben_Dallas’s picture

Status: Closed (works as designed) » Needs review

Caching is disabled for development purposes, and the problem persists even if I clear all caches manually.

markcarver’s picture

Status: Needs review » Closed (cannot reproduce)

Then you have something else wonky going on which falls outside the scope of this project. This project does not handle block visibility in any way.

Korben_Dallas’s picture

Understood, thank you.

It suppose it could be possible I simply don't have the subtheme installed correctly and will review that. Should that be the cause, I will update this issue to reflect that.

Korben_Dallas’s picture

Status: Closed (cannot reproduce) » Closed (works as designed)

Wonky indeed.
Creating a new Bootstrap sub theme and switching to that seems to have resolved the problem. Thanks for checking and steering me in the right direction.