When I create a view with 'Comment: View link' field, link is displayed but it ignores the division into pages and does not add '?page=page_num' to the URL.

The following patch solves this problem. Please review.



dawehner’s picture

Its just implemented how drupal core does it :)
This was a long long problem in drupal until drupal7. There is a fix in drupal7, but i don't think that this will be fixed in drupal6.

I think this shouldn't be fixed in views.

esmerel’s picture

Also, no patch is attached.

ershov.andrey’s picture

new1.34 KB

Sorry, there is my patch.

ershov.andrey’s picture

Status:Active» Needs review
merlinofchaos’s picture

Status:Needs review» Needs work

Aside from poor code style (spacing is wrong) this patch runs a query for every field rendered. Unless that is impossible to avoid, we should not do that, it is highly inefficient. We use pre_render() to try to run a single query when we can.

esmerel’s picture

Status:Needs work» Closed (won't fix)

No work done on patch for more than 3 months.

jcisio’s picture

Version:6.x-2.8» 6.x-2.x-dev
Status:Closed (won't fix)» Needs work

No patience?

paolomainardi’s picture

Any new about this problem ? On D5 we was using this one: http://drupal.org/project/comment_redirect

They say that in D6 6.x-dev version the problem is now solved, with the last dev version i see that this issue is still there.

Thanks a lot.

esmerel’s picture

Not unless someone wants to work on that patch, no.

paolomainardi’s picture

Finally, i've just solved the problem using Permalink module, that seems to be the same approach taken into D7.