As long as I'm using ImageCache I always wanted to give some presets more descriptive names (namespace is limited and not really good to describe the preset).

Heres a patch that adds the possibility to enter descriptive names for presets. These names are used in listings (e.g. Views or CCK field output selection).

I've added some screenshots to show the new behaviour.

Members fund testing for the Drupal project. Drupal Association Learn more


stBorchert’s picture

Btw.: committing this patch would require nearly all modules depending on ImageCache to rewrite some parts of their code.
Maybe ist better to not change the name of column "presetname" to "presetnamespace" but name the new column "presetrealname" (or something like this).
That would still give users the possibility to enter descriptive names but doesn't force other modules to change their code.
On the other hand the columns are now (with this patch) named according to their contents.

stBorchert’s picture

Other approach, same result (without renaming column "presetname" to "presetnamespace" and forcing other modules to rewrite their code).

stBorchert’s picture

One minor comment change.

smk-ka’s picture

I like this. It would also reduce the likelihood to rename presets and having to update all CCK field displays and Views, as described in #596620: Renaming ImageCache preset invalidates formatter display of CCK fields. .

sandrewj’s picture

Status: Needs review » Closed (duplicate)
stBorchert’s picture

Status: Closed (duplicate) » Needs review

@sandrewj: sorry for re-opening, but this patch has been much older and is on a way to make it in core, too (see #606598: Human readable image-style names).
If you may like to join forces, please update this one here and do not open (or feed) another issue.

sandrewj’s picture

I don't mind leaving this one open. The patch I submitted on the other issue is pretty similar and solves the same issues.

Does this issue need to stay open because it is referenced in the D8 core issue?
Would the hope be for the patch to be accepted into the D8 core and then backported to D7 core and to this D6 module or can development continue on this issue independently?

sandrewj’s picture

Status: Needs review » Needs work

For now I am marking this as needs work. When the #606598: Human readable image-style names gets finalized/committed for D8 core it can be ported to this module.

fizk’s picture

Issue tags: +ImageCache 3

Marking as ImageCache 3.x Todo.

klonos’s picture

Status: Needs work » Postponed

...actually, the proper status is postponed, but I feel #606598: Human readable image-style names is reeeally close to commit! :D

andypost’s picture

klonos’s picture

Status: Postponed » Active

...back to active then. Right?