I've created a uprofile node type by myself and added required cck fields which showed by in the user profile page. However, the comment form and comments are not showing up. Comment is enabled for uprofile node type and permissions are set correctly.

I think since, I created the uprofile node by myself rather than importing it, it might have been some problem due to it.

Please let me know what i'm missing?


Michelle’s picture

Project:Advanced Profile Kit» Chaos tool suite (ctools)
Version:6.x-1.0-beta1» 6.x-1.0
Status:Active» Postponed (maintainer needs more info)

It doesn't matter if you made it yourself. The comment form and comments are part of CTools, not APK. They should work just fine as long as you have a node context, the user in question has a profile node created, and comments are enabled on that node (not just the node type). If all those conditions are true, then I don't know what else could be wrong so I'm moving this over to the CTools queue.


NeoID’s picture

I'm having the same issue. Don't know what more information I can add to this issue...
I had it working, but something broke it, so now only the old comments are displayed and no form to add more. I'm not sure what module or setting caused it, sorry :/

Michelle’s picture

Status:Postponed (maintainer needs more info)» Closed (duplicate)
Eidolon Night’s picture

I'm having the same issue. What this ever fixed? I updated to the latest dev of ctools and panels, but no luck.

Eidolon Night’s picture

Version:6.x-1.0» 6.x-1.x-dev
Category:support» bug
Status:Closed (duplicate)» Active

I'm switching this to active since one of these issues should get resolved, and Michelle thinks it's a ctools issue.

I've even tried custom panels in which I manually try printing comments. No luck. I'm using the combination of content profile, advanced profile kit, panels, and ctools. I think that this is a fairly common combination of modules. Am I wrong in my assumption? Are people simply not using comments on profiles? Or is this a niche issue?

I'll be setting up a new test environment to do more testing.

Michelle’s picture

Well, I can't guarantee it's CTools causing the problem but it's not an APK issue because APK doesn't use the comment form. Last time I tried it, the comment form worked just fine in Page Manager but that was a long time ago. I haven't used node comments on profiles since I switched to FBSS. I think it's fairly niche. Using comments on the profile node is the old way of doing it with better methods available now. However, there's no reason why you shouldn't be able to put a comment form on a page variant so it should be fixed if it is actually broken and not just a configuration issue.


merlinofchaos’s picture

Status:Active» Postponed (maintainer needs more info)

It occurs to me that one issue might be that if you're using the *nodecomments* module, the default comments form isn't going to show up because normal comments are disabled. You need to use the nodecomment form that nodecomment module provides.

I've doublechecked this and the comment form is showing up for me when I test, so I suspect it's node comment related.

kmv’s picture

I'm not sure if this is exactly the same problem, but I think I have found a CTools problem that prevents comments rendering on nodes that are in a panel.
#672722: Add compatibility with panels

sirkitree’s picture

I have replicated this on a fresh install. Steps:

1. enable node_view panel page.
2. create new variant
3. variant selection criteria set for node type 'page'
4. flexible layout
5. create new column on the right with a row and region named 'right'
6. in the first column add Node > Content
7. in the second column add Node > Comments and Node > Comment Form

Node template | drupal-6

Upon viewing the node you can see that it is indeed using a panel and that the node content is showing, but not the comments or form.

test | drupal-6

sirkitree’s picture

Hrm, so my problem here was that I created the node BEFORE i enabled comments on the node type. therefor the individual node did not have the comment form, but new ones do!

Letharion’s picture

Category:bug» support
Status:Postponed (maintainer needs more info)» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.