Dear all
I am installed drupal in local machine following configuration
Window2000
xampp-win32-1.7.1.zip
drupal-6.12.tar.gz

When I type the url http://localhost/drupal/ following error is coming
Parse error: parse error in C:\xampp\htdocs\drupal\sites\default\settings.php on line 92
Please guide me

Vikas Salunkhe

Comments

ppblue’s picture

Please do give us more clearly details about your installation proccess. I can't figure out what was happened. Thanks.

svikas’s picture

Hi
Thank you for the reply for my issue
I follow the following step for installation process
1)Extract xampp-win32-1.7.1.zip file in c drive
2) Open XAMPP Control Panel Double click xampp-control.exe to open XAMPP Control Panel Application.
3) Start Apache and MySQL ServicesClick
4) Test XAMPP installation
5) Create ‘drupal’ database in mysql
6) Set password for MySQL
7) Extract drupal-6.12.tar.gz files to C:\xampp\htdocs folder
8) Rename extracted folder to ‘drupal’
9) Open ‘drupal’ folder, copy default.settings.php to the same folder and rename it to settings.php.
10) Open settings.php and enter $db_url = ‘mysql://root:admin@localhost/drupal’;
11) Now, scroll down and enter $base_url = ‘http://localhost/drupal’; // NO trailing slash
12) Open Web browser and enter http://localhost/drupal in the address bar

Then error is coming browser Parse error: parse error in C:\xampp\htdocs\drupal\sites\default\settings.php on line 92

Please guide me

Vikas Salunkhe

maheshsonline’s picture

Your error is in 10) Open settings.php and enter $db_url = ‘mysql://root:admin@localhost/drupal’; Here you have basically said that you have already created a database named "drupal" in mysql and has got a username "root" with password "admin". Please verify the same and try again.

svikas’s picture

As for your direction I check username, password and database name are correct but when I click CD Collection (http://localhost/xampp/) following error is coming
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in C:\xampp\htdocs\xampp\cds.php on line 64
Could not connect to database!
Is MySQL running or did you change the password?

Please guide me