Ran into a problem where MySQL 5.7 has changed the user table schema, dropping the Password field in place for authentication_string as can be seen in the following release notes - https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-6.html

Symptoms show up with new sites and cloneing, I think it has to do with DB imports, see examples

Database import failed: ERROR 1210 (HY000) at[error]
line 21: Incorrect arguments to EXECUTE

or verbose

Importing database using command: mysql --defaults-file=/dev/fd/3 newsite [31.57 sec, 10 MB] [notice]
Database import failed: ERROR 1210 (HY000) at line 21: Incorrect arguments to EXECUTE [error]
[31.58 sec, 30.01 MB]
Returned from hook drush_db_provision_deploy [31.57 sec, 10 MB] [debug]
Changes made in drush_provision_drupal_pre_provision_deploy have been rolled back. [31.59 sec, 10 MB] [debug]
Dropping database newsite [31.59 sec, 10 MB] [notice]
Executing: mysql -u intntnllyInvalid -h 'localhost' -P '3306' -e "SELECT VERSION\(\)"
ERROR 1045 (28000): Access denied for user 'intntnllyInvalid'@'localhost' (using password: NO)
Executing: mysql -u intntnllyInvalid -h 'localhost' -P '3306' -e "SELECT VERSION\(\)"
ERROR 1045 (28000): Access denied for user 'intntnllyInvalid'@'localhost' (using password: NO)
Revoking privileges of newsite@localhost from

Comments

leenx created an issue. See original summary.

leenx’s picture

Greetings ... I am not sure this issue is related to issue https://www.drupal.org/node/2770819

I have tried the suggestions posted in the https://www.drupal.org/node/2770819 and not been able to make progress.

Anything else that might be useful to try?