After updating to rc1 I am getting the following errors when trying to run update.php. It looks like the autoloader is looking for the ConfigFilterServiceProvider in the wrong place.

| Comment | File | Size | Author |
|---|---|---|---|
| Selection_530.png | 234.42 KB | chrissnyder |
After updating to rc1 I am getting the following errors when trying to run update.php. It looks like the autoloader is looking for the ConfigFilterServiceProvider in the wrong place.

| Comment | File | Size | Author |
|---|---|---|---|
| Selection_530.png | 234.42 KB | chrissnyder |
Comments
Comment #2
bircherHello
Thank you for the screenshot that shows what exactly is going on.
This is due to the fact that this file no longer exists thanks to: #2873623: use service decoration
However, this is not a problem since when you update the module with composer, the autoloader is rebuilt. It looks as if you had a problem with the apc cache though.
Could you verify that this issue persists when clearing the apc cache and rebuilding the autoloader? if it does it is a very serious issue.
Comment #3
chrissnyderClearing the apc cache resolved my issue. Thank you for your help!
Comment #4
danepowell commentedAt least in some environments, it's specifically the APC user cache that needs to be cleared. I'm not sure that this can be done from the command line, since APC maintains separate caches for CLI and Apache, which makes actually doing this cache clear in production a pretty big pain.
Comment #5
greg.harveyThis tool, cachetool, might help:
https://github.com/gordalina/cachetool
We use it in deployment scripts to make sure the actual *web server* opcode cache is cleared, to avoid %weirdness. :-)