Hello there,

Installing d8.3 on apache server with PHP5.6
See it here;
http://openhandweb.org/d8-test1/core/install.php

Errors below;

Additional uncaught exception thrown while handling exception.
Original
ReflectionException: Class \Drupal\Core\Routing\Router does not exist in ReflectionMethod->__construct() (line 87 of /home/openhand/public_html/d8-test1/core/lib/Drupal/Core/DependencyInjection/Compiler/TaggedHandlersPass.php).

ReflectionMethod->__construct('\Drupal\Core\Routing\Router', 'addRouteEnhancer') (Line: 87)
Drupal\Core\DependencyInjection\Compiler\TaggedHandlersPass->process(Object) (Line: 104)
Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object) (Line: 590)
Symfony\Component\DependencyInjection\ContainerBuilder->compile() (Line: 1284)
Drupal\Core\DrupalKernel->compileContainer() (Line: 873)
Drupal\Core\DrupalKernel->initializeContainer() (Line: 18)
Drupal\Core\Installer\InstallerKernel->initializeContainer() (Line: 465)
Drupal\Core\DrupalKernel->boot() (Line: 414)
install_begin_request(Object, Array) (Line: 114)
install_drupal(Object) (Line: 44)

Additional

Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "theme.manager". in Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition() (line 816 of /home/openhand/public_html/d8-test1/vendor/symfony/dependency-injection/ContainerBuilder.php).

Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition('theme.manager') (Line: 456)
Symfony\Component\DependencyInjection\ContainerBuilder->get('theme.manager') (Line: 674)
Drupal::theme() (Line: 22)
_drupal_maintenance_theme() (Line: 710)
drupal_maintenance_theme() (Line: 967)
install_display_output(Array, Array, Array) (Line: 264)
_drupal_log_error(Array, 1) (Line: 570)
_drupal_exception_handler(Object)

Any suggestions most welcomed.
With thanks,

Comments

looklively created an issue. See original summary.

cilefen’s picture

Issue tags: -installation

Is this an unmodified, plain Drupal core?

looklively’s picture

Hi,

Thanks for looking.
And thanks @cilefen for your reply.

This issue was due to an improper upload of the sites files.
I presume the upload was interrupted and did not complete properly.
My connection is sometimes erratic.
D8 install now progressing as it should

Cheers,
:)

looklively’s picture

Status: Active » Closed (works as designed)