Hi there,

I'm not sure to be in the right session of the forum.

I just change my cutommer's website hosting and things appear.

When i tried to upload an image with a field in a node i saw the circle turned.
The file is upload (i can see it on ftp) but i can't see it in "thumb".
More, i've got error in the console :

http://www.mywebsite.org/node/738/edit?element_parents=field_image/widget/0&ajax_form=1&_wrapper_format=drupal_ajax 500 (Internal Server Error)

XHR finished loading: POST "http://www.mywebsite.org/node/738/edit?element_parents=field_image/widget/0&ajax_form=1&_wrapper_format=drupal_ajax".

Uncaught D…l.AjaxError {message: "↵Une erreur HTTP AJAX s'est produite.↵Code de stat…StatusText: Internal Server Error↵ResponseText : ", name: "AjaxError"}

Do you have any idea ?
Thanks in advance

Regards
Jo

Comments

Jaypan’s picture

When you get a 500 error, there will be something in either your Drupal log, your PHP log, or your apache log. You need to track down the error to get a better idea of what is happening.

CCG’s picture

Hi thanks for your answer.

I checked on all log...
The only thing I saw is :
POST /node/738/edit?element_parents=field_image/widget/0&ajax_form=1&_wrapper_format=drupal_ajax HTTP/1.1" 500

Jaypan’s picture

That's not it.

CCG’s picture

ip.ip.ip.ip www.mydomain.org - [21/Mar/2017:09:44:44 +0100] "POST /node/738/edit?element_parents=field_image/widget/0&destination=/admin/content&ajax_form=1&_wrapper_format=drupal_ajax HTTP/1.1" 500 25 "http://www.mydomain.org/node/738/edit?destination=/admin/content" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"

nop the same ... -_-

Jaypan’s picture

I mean that's not the error log, that's the access log. You need to find the error that is being generated in the error logs.

CCG’s picture

I check in all the lof my hosting give to me: error / web / ftp / out and i find nothing ...

The only thing i found is in the chrome console .
Something like this :

name:"AjaxError"
__proto__:Error at http://www.mydomain.org/core/misc/ajax.js?v=8.2.7:181:32 at http://www.mydomain.org/core/misc/ajax.js?v=8.2.7:1344:3

constructor:(xmlhttp, uri, customMessage)

arguments:[Exception: TypeError: 'caller' and 'arguments' are restricted function properties and cannot be accessed in this context. at Function.remoteFunction (<anonymous>:2:14)]

caller:[Exception: TypeError: 'caller' and 'arguments' are restricted function properties and cannot be accessed in this context. at Function.remoteFunction (<anonymous>:2:14)]

length:3

name:""

Try to find something in google but ... still same ...

I just create a ticket to know why i can't see that log ...

regards
Jonathan

Jaypan’s picture

You won't be able to see 500 errors in the browser, only on the server.