Occurs for me when running in Acquia DevDesktop under PHP 5.3.29 with E_STRICT enabled.

Working on a patch. Stand by.

Comments

mlewis_duoconsulting created an issue. See original summary.

mlewis_duoconsulting’s picture

This fixes the problem for me in 6.x-2.10.

mlewis_duoconsulting’s picture

This is the same patch (basically), applied to the latest 6.x-2.x

fuzzy76’s picture

Status: Needs review » Reviewed & tested by the community

As far as I can tell, this is handled for 3.x in #2327005: E_STRICT compliance

#2 was tested against 6.x-2.10 and worked like a charm.