Change the method names to be clear that fetch() and getCount() is about unprocessed messages.

Support from Acquia helps fund testing for Drupal Acquia logo

Comments

ModernMantra created an issue. See original summary.

ModernMantra’s picture

Issue summary: View changes
drobnjak’s picture

Assigned: Unassigned » drobnjak
miro_dietiker’s picture

Title: Change the name of methods » make clear fetch() and getCount() is about unprocessed mail, rename

The title is so much general that it you don't know
- what is affected
- why / what is the problem

miro_dietiker’s picture

There is some overlap to #2803981: make clear fetch() and getCount() is about unprocessed mail, rename where we started to rename the method getCount() already.

drobnjak’s picture

Status: Active » Needs review
FileSize
7.39 KB

Status: Needs review » Needs work

The last submitted patch, 6: make_clear_fetch_and-2803981-6.patch, failed testing.

drobnjak’s picture

Status: Needs work » Needs review
FileSize
1.22 KB
8.76 KB
AsadKamil’s picture

Hi All,
This patch is working fine .Thanks

root@asad-Vostro-3550:/var/www/html/git/inmail# git apply -v make_clear_fetch_and-2803981-8.patch 
Checking patch inmail.module...
Checking patch inmail_mailmute/src/Plugin/inmail/Handler/MailmuteHandler.php...
Checking patch inmail_mailmute/src/Plugin/mailmute/SendState/CountingBounces.php...
Checking patch src/DelivererListBuilder.php...
Checking patch src/Form/DelivererListForm.php...
Checking patch src/Plugin/inmail/Deliverer/FetcherBase.php...
Checking patch src/Plugin/inmail/Deliverer/FetcherInterface.php...
Checking patch src/Plugin/inmail/Deliverer/ImapFetcher.php...
Checking patch tests/modules/inmail_test/src/Plugin/inmail/Deliverer/TestFetcher.php...
Checking patch tests/src/Kernel/DelivererTest.php...
Applied patch inmail.module cleanly.
Applied patch inmail_mailmute/src/Plugin/inmail/Handler/MailmuteHandler.php cleanly.
Applied patch inmail_mailmute/src/Plugin/mailmute/SendState/CountingBounces.php cleanly.
Applied patch src/DelivererListBuilder.php cleanly.
Applied patch src/Form/DelivererListForm.php cleanly.
Applied patch src/Plugin/inmail/Deliverer/FetcherBase.php cleanly.
Applied patch src/Plugin/inmail/Deliverer/FetcherInterface.php cleanly.
Applied patch src/Plugin/inmail/Deliverer/ImapFetcher.php cleanly.
Applied patch tests/modules/inmail_test/src/Plugin/inmail/Deliverer/TestFetcher.php cleanly.
Applied patch tests/src/Kernel/DelivererTest.php cleanly.
root@asad-Vostro-3550:/var/www/html/git/inmail#
miro_dietiker’s picture

@AsadKamil This post doesn't help. The testbot already confirmed this:

8.x-1.x: PHP 5.5 & MySQL 5.5, D8.3 746 pass

With your long post, issues just get longer and it's hard to focus on the relevant points.

I'm pretty sure there are other tasks that you can perform that would add great value.

miro_dietiker’s picture

Status: Needs review » Fixed

Committing this to move forward with the interface.

The internal state keys (see FetcherBase) are still using old terms such as "remaining"...

  public function getCountUnprocessedMessages() {
    return \Drupal::state()->get($this->makeStateKey('remaining'));
  }

The naming of the internal states is updated in some other issue where it was also already discussed.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.