Currently the default UI map uses MapQuest. However, MapQuest now requires an API key in order to use their layers. We already have an issue for adding API configuration here: #2764987: Provide MapQuest API configuration

This task is to change the default UI map to use OpenStreetMap instead, which does not require an API key.

CommentFileSizeAuthor
#5 osm_for_default-2764999-5.patch1.77 KBdrasgardian
Members fund testing for the Drupal project. Drupal Association Learn more

Comments

m.stenta created an issue. See original summary.

  • Pol committed 21c2a18 on 7.x-3.x
    Issue #2764999: Use OpenStreetMap for default UI map
    
Pol’s picture

Status: Active » Fixed

Thanks, it's fixed.

m.stenta’s picture

Great thanks Pol!

drasgardian’s picture

Version: 7.x-3.x-dev » 7.x-2.x-dev
Status: Fixed » Needs review
FileSize
1.77 KB

Can we address this in the 2.x branch also?

In 2.x the center and bounds form is hard-coded to use mapquest_osm. Attached patch also changes that to osm_mapnik.

nickbits’s picture

Can confirm the patch for 2.x works for me.