Just a word of warning about Ubuntu 16.04, which was released today: It upgrades you to PHP7 but leaves behind a number of components that Drupal requires, notably the CLI version of PHP (required by Drush), GD, curl, mbstring, and probably a few others. I had to spend about 20 minutes adding Apache modules before I was able to get my localhost Drupal installation running again.

Also, "apt-get install" doesn't necessarily restart Apache, so don't forget to do that manually to pick up your changes.

Once I got the Web installation working, I was able to "drush up" to Drupal 8.1.0 without incident.

Comments

quid.oblitus’s picture

Recall what those might have been? Thx.

augustofagioli’s picture

thanks for sharing

Scott_McKinnis’s picture

Why would "apt-get install" restart apache? "apt-get install" should be used for installing packages via apt, right? Or am I missing something?