Problem/Motivation

FlagResetForm includes a property "flagService" but it's really for the FlaggingService.

Proposed resolution

Rename the property from flagService to flaggingService.

Remaining tasks

Create patch.

User interface changes

None.

API changes

None.

Data model changes

None.

Support from Acquia helps fund testing for Drupal Acquia logo

Comments

socketwench created an issue. See original summary.

sdstyles’s picture

Status: Active » Needs review
FileSize
1.04 KB
socketwench’s picture

Status: Needs review » Needs work
+++ b/src/Form/FlagResetForm.php
@@ -37,7 +37,7 @@ class FlagResetForm extends ConfirmFormBase {
   public function __construct(FlaggingServiceInterface $flag_service) {
-    $this->flagService = $flag_service;
+    $this->flaggingService = $flag_service;

We should rename the parameter to $flagging_service too.

sdstyles’s picture

Status: Needs work » Needs review
FileSize
1.23 KB

  • socketwench committed 1f04efb on 8.x-4.x authored by sdstyles
    Issue #2708681 by sdstyles: Changed FlagResetForm property flagService...
socketwench’s picture

Status: Needs review » Fixed

Perfect. Thanks!

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.