# Summary

This module alters the default search box in many ways. If you need to have options available like in advanced search, but directly in the search box, this module is for you.

The 8.x-1.0-beta branch is usable, and instead of overriding the default search block like it did with D6&7, it provides its own block(s) (like the Custom Search Blocks submodule in previous versions, but easier to do now with D8 core). Settings for the results page are now set per search page, not global anymore. It still misses the upgrade path, and i18n support.

# Project URL

https://www.drupal.org/project/custom_search

# Where is the code?

https://www.drupal.org/project/custom_search

# Estimated completion date

Unknown

# Dependencies

Unknown

# Who's doing the port?

Unknown

# What help do they need?

Unknown

# D8 roadmap

Unknown

# Background and reference information

Unknown

Comments

legaudinier created an issue. See original summary.

joegraduate’s picture

Title: [custom_search] Module Human-Readable Name (Issue Template) » [custom_search] Custom Search
Red2015’s picture

Hope this is the right place to register some problems I've come across? I have installed the module, and if the block is added to a region without editing any of the default settings it it renders the page as normal.

If any of the form settings are changed however, the page displays as if the stylesheet is missing, and displays the content up to where the form is placed. The developer console displays a '500' error message.

Also, whilst this module is installed, I cannot add a new content type. Hitting 'save' leads to a blank '500' error page. I uninstalled the module, tested it, and re-installed it to double check the error was connected to this module. it was.

The only thing I would mention is the default search block installed with drupal was deleted by mistake a while ago, could this have anything to do with it? Either way would be keen to know what is going on! Thanks.

dgilbert’s picture

We installed the latest Custom Search beta module on our 8.2.5 site but the Custom Search block does not show up under admin/structure/block layout/type. At one point (for no apparent reason) the Custom Search block did show up on the admin menu but the page was not found (404), and after the cache was flushed the option disappeared from the menu once again. The only indication we can find that the module is installed at all is the added global settings when editing a (content) search page. Any suggestions?