This may already exist and I'm not aware of it, but I think it'd be handy to be able to allow modules to define a minimum required version. For example, right now a project I'm working on is using panopoly_core, and it has the jquery_update version set to 1.7. However, we have a need for 1.8, which causes this module to be perpetually overridden (disallowing drush fra). However, if there was a way for each module to simply make a suggestion for a minimum version requirement, that would alleviate that issue and allow future jQuery version updates without issue. Perhaps this could be as simple as exposing a hook?

hook_jquery_update_minimum_version() {
  return '1.7';

The highest value out of all the hooks would then set the minimum value which, if not met, would elicit an error.

Members fund testing for the Drupal project. Drupal Association Learn more


Albert Volkman created an issue. See original summary.

Albert Volkman’s picture

Issue summary: View changes
Albert Volkman’s picture

Version: 7.x-2.x-dev » 7.x-3.x-dev
Status: Active » Needs review
2.45 KB

Here's a check via hook_requirements.