I really think we should not call the staging directory of CMI "staging". I spoke to a lot of people that already use Drupal 8 in production and they all agree that it's a bad name. Because it is confused a lot with actual staging environments. Some CMI Workflows actually have separate folders for different hosting environments (like "to_dev", "from_prod", "staging") and then it is even more confusing.
Inthe staging directory was introduced. There it was decided to call it "staging" as the proposed "import" name was not good enough, as we use that folder also for exporting of configuration.
So I would suggest to actually call it "import-export" or if we don't like the two name system, maybe "synchronization" or "sync"? (we call it anyway synchronization in the UI)
I just think we will start to confuse a lot of people, because when you tell somebody "staging" they immediately think about staging environments
+ Write Patch
+ Create change record
- Inform contrib modules to use CONFIG_SYNC_DIRECTORY instead of CONFIG_STAGING_DIRECTORY
User interface changes
- Constant name CONFIG_STAGING_DIRECTORY probably changes
Change record: https://www.drupal.org/node/2574957
Beta phase evaluation
|Issue priority||Major because the earlier we fix this issue, the less people are already confused by it. Especially before the RC1|
|Prioritized changes||The main goal of this issue is to make a better developer experience. 8 ships with CMI, which nobody ever knew before, let's make it as streamlined as possible, so that we don't scare people away.|
|Is BC?||Yes, fully backwords compatible to modules that still depend on CONFIG_STAGING_DIRECTORY|
FAILED: [[SimpleTest]]: [PHP 5.5 MySQL] Unable to apply patch 2487588.70.patch. Unable to apply patch. See the log in the details link for more information. View
FAILED: [[SimpleTest]]: [PHP 5.5 MySQL] Unable to apply patch 2487588.69.patch. Unable to apply patch. See the log in the details link for more information. View