How to reproduce:

  1. On first instalation step choice "Russian" as default site language;
  2. Use standart profile;
  3. Create one Article and add several comments to this article;
  4. Add new RTL language, for example "Arabic";
  5. Set "Arabic" language as default language.

Comments

zestagio’s picture

zestagio’s picture

Issue summary: View changes
andypost’s picture

Issue summary: View changes
Issue tags: +Twig, +frontend, +D8MI
andypost’s picture

Issue tags: +Needs manual testing

maybe comments saved before language change are rendered in previous language....

zestagio’s picture

I did two tests.

Case 1:
Install site with "English" as default site language;
Use standart profile;
Create one Article and add several comments to this article;
Add new RTL language, for example "Arabic";
Set "Arabic" language as default language;
In this case styles are ok

Case 2:
Install site with "Russian" as default site language;
Use standart profile;
Create one Article and add several comments to this article;
Add new RTL language, for example "Arabic";
Set "Arabic" language as default language;
In this case styles are broken

Cottser’s picture

Screenshots look like they are from Bartik, can you reproduce with any other theme? Sounds like it may be Bartik specific.

zestagio’s picture

FileSize
68.99 KB
65.71 KB

I did test for seven theme.

In case 1 styles for comment's links are broken (seven-rtl-en-ar.png).
In case 2 styles for comments are broken (seven-rtl-ru-ar.png).

Cottser’s picture

Issue tags: +CSS, +Needs screenshots

Thanks @zestagio.

skippednote’s picture

Issue summary: View changes
Status: Active » Needs review
FileSize
178.2 KB
168.99 KB

I tried both the cases on latest beta and it seems to be working fine with both Bartik and Seven.

zestagio’s picture

I tested latest beta too. No ok for me. Tested on Windows 7 (Firefox 37.0.2, Google chrome 42.0.2311.135 m) and Ubuntu 12.04 (Firefox 37.0.2, Chromium 37.0.2062.120). Reproduced on all browsers

Cottser’s picture

Status: Needs review » Active

Needs review is for when we have a patch. Thanks for the testing folks!

dbjpanda’s picture

Issue tags: -Needs screenshots

Screenshots are there already.

emma.maria’s picture

Issue tags: +Bartik, +DrupalBCDays

Version: 8.0.x-dev » 8.1.x-dev

Drupal 8.0.6 was released on April 6 and is the final bugfix release for the Drupal 8.0.x series. Drupal 8.0.x will not receive any further development aside from security fixes. Drupal 8.1.0-rc1 is now available and sites should prepare to update to 8.1.0.

Bug reports should be targeted against the 8.1.x-dev branch from now on, and new development or disruptive changes should be targeted against the 8.2.x-dev branch. For more information see the Drupal 8 minor version schedule and the Allowed changes during the Drupal 8 release cycle.

emma.maria’s picture

Issue summary: View changes
Status: Active » Closed (cannot reproduce)
FileSize
151.06 KB
210.89 KB

Updated screenshots were needed as the last were a year ago. I can no longer replicate this issue in any theme - Seven or Bartik.
 

 

vprocessor’s picture

Hi guys, I checked this on simplytest.me this steps https://www.drupal.org/node/2480497#comment-9878663

case 2

can't reproduce, all is ok