Hi!

I'm working with jQuery Update and now I need to use a different jQuery version from any of given in the module.

I think would be a great jump to add a "user defined" option in "Default jQuery Version" to manually include jQuery and jQuery UI versions to use (of course, this option must enforce to use CDN).

This would let developers to change to the desired trueversion if not yet available in jQuery Update... and avoid to download directly to the theme folders.

If you think it's interesting, I could help on this feature.

Regards,
Daniel

Comments

markcarver’s picture

Status: Active » Closed (won't fix)
Issue tags: -jQuery Version, -jquery ui version, -CDN
Related issues: +#1500118: Use jQuery.noConflict() to get newest versions

No. See related issue for reasoning.

dtamajon’s picture

Related issue is a completely different proposal... One thing is to allow upload a JQuery version, so you can add a new version to the selectable list without waiting to a new "JQuey Update" release, and another one is to load all the JQuery version in the client side.

markcarver’s picture

Title: Allow any version » Detect custom jquery in sites/*/libraries
Version: 7.x-2.4 » 7.x-3.x-dev
Status: Closed (won't fix) » Active
Parent issue: » #2852350: [jquery_update] 7.x-3.0 stable release
Related issues: +#1869928: Better CDN/API/automation support

Ah, I see what you're saying.

... different jQuery version from any of given in the module

This part is what was tripping me up, I read it as "different jQuery version as declared from any module", thinking that we'd let module dictate what version they coded against. Which, I'm sure you'd agree, would be ridiculously difficult and completely unmanageable.

I think what you're referring to is more #1869928: Better CDN/API/automation support. Which has a related child issue to allow a "custom" CDN.

I think we could even augment CDNs so it downloads those files so it can be served locally, either always or as a fallback as well.

---

Regardless, I think one thing that never made it in is the ability to manually upload a version of jquery to sites/*/libraries, which would truly allow for anything "custom". So I'm going to repurpose this issue for that.

P.S. Sorry for closing, was simply doing a general IQ purge for #2852350: [jquery_update] 7.x-3.0 stable release.

dtamajon’s picture

Yes, indeed.

dtamajon’s picture

Status: Active » Closed (duplicate)
markcarver’s picture

Status: Closed (duplicate) » Active

No, I'm re-purposing this issue.