Hey there,

after using the plugin and upgrading jQuery and jQuery.UI > 1.9.X we had problems with Ctools dialogs. Since the fix that is provided in the Ctools issues is not quite comforting, we thought it might be a good idea to add jQuery.UI choosing to this module.

The patch is pretty big (~8MB).

It is attached in first comment, because of the conventions and stuff.

I hope we missed nothing there.

Greetings
func0der

Members fund testing for the Drupal project. Drupal Association Learn more

Comments

func0der’s picture

func0der’s picture

Issue summary: View changes
func0der’s picture

Please be aware, that in jQuery UI 1.9.2 release that is download-able from jqueryui.com there is a bug in the "base" theme in the minified css files.
Bug report is opened here: http://bugs.jqueryui.com/ticket/10688

If you want to use the minified version of the css, you have to compile it yourselves, please. I update the patch as soon as the jQuery UI 1.9.2 package is updated.

func0der’s picture

FileSize
7.95 MB

Okay, whatever. Patch incoming ^^

func0der’s picture

Version: 7.x-2.4 » 7.x-2.5
Status: Active » Needs review
FileSize
7.95 MB

Updated for module version 2.5.

func0der’s picture

FileSize
7.95 MB

Fixed a little typo in the replace function.

func0der’s picture

Could someone PLEASE!!! finally merge this or at least have a look at it, so it can get merged?

It is a pain in the ass to apply this patch everytime after an update and I am pretty sure that I am not the only one who needs this functionality.

cmseasy’s picture

I think it should be patched against latest dev: 7.x-3.x-dev instead of 2.5 of you want some responce.

markcarver’s picture

Title: Different jQuery.UI versions » Allow detection of different jQuery UI libraries in sites/*/libraries/jquery.ui
Version: 7.x-2.5 » 7.x-3.x-dev
Status: Needs review » Needs work

After having to recently sift through all the external libraries and figure out their licensing issues (#1857042: [jquery_update] 3rd party libraries and #2534056: Remove unused and NON-MIT/GPL licensed or compatible code), jQuery UI is the largest and hardest to maintain just from that aspect alone. This issue is asking to make it exponentially more difficult to maintain.

I am saying NO to the above patch (it's just too big).

I am saying YES to the "idea" though. We could easily provide the UI option for different jQuery UI versions detected in sites/*/libraries/jquery.ui (probably via Libraries API support, not a requirement... just support), but I think that is about as far as any maintainer would be willing to go.

And yes, as this is a feature request... all new code should be against the latest 7.x-3.x branch.

timur_eatsmarter’s picture

FileSize
7.63 MB

Dedicated to jQuery Update 2.7
Fixed typo and removed handling of non-existing files.