DanChadwick commented 3 days ago
Category: Task » Feature request
Status: Needs review » Closed (won't fix)
Thanks for your work on this. I suggest that you create your own webform-related module. I'm going to close this since there is no issue or patch for webform core.

Comments

joseph.olstad’s picture

Title: newer versions of webform require a new patch in order to be deployable » newer versions of webform might require a new patch in order to be deployable

Investigation required.

If we want the latest version of webforms we might have to write a patch for uuid support ?

maybe he's just closing old stale issues? Not sure how much work it would take to get the old patch working on the latest commit of webform or latest tagged release. I read in another issue that Dan Chadwick was talking about trying to publish a 4.0 release soon.

joseph.olstad’s picture

Sounds like the maintainer of the webform project is pushing back on his queue and really wants to publish a 4.0 release of the webform module as it's been in alpha, beta and 'rc' for quite some time and he's been very active lately trying to squash release blockers.

sylus’s picture

Status: Needs review » Closed (duplicate)

The patch will always apply to Webform because it only adds files to Webform without modifying any of them so regardless of changes being made upstream patch will still apply. The larger question is if we want to create our own webform_uuid module but for now the parent issue is reopened so can continue discussion there and get the community to come up with a solution.

jmdeleon’s picture

Status: Closed (duplicate) » Needs review

I didn't want to open up a new issue on this, but it appears that a Webform UUID module was created some time ago, to replace the old patch in issue #2076483: Support UUIDs for Feature Exporting. Adding this module might reduce the patch-tag being played on Webform and help with updates.

sylus’s picture

I confirmed that the patch we are using and the code in webform_uuid are exactly the same. The make file has been changed to:

; WetKit Webform Makefile

api = 2
core = 7.x

; Modules

projects[webform][version] = 4.13
projects[webform][subdir] = contrib

projects[webform_uuid][version] = 1.0
projects[webform_uuid][subdir] = contrib

With webform no longer being patch and webform_uuid now existing under profiles/wetkit/modules/contrib/* instead of under webform.

sylus’s picture

Status: Needs review » Fixed

  • sylus committed a814b41 on 7.x-4.x
    Fixed WetKit Webform for Issue #2330581: newer versions of webform might...

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.

sylus’s picture

Note I can't call newer versions as they are pushed against master and not the 7.x-1.x branch. Someone should politely ask maintainer to fix this.