One thing that came up frequently during usability testing was how many new users go to "access rules" looking for permissions. At a minimum it should be renamed.
However, drupal_is_denied() is also the slowest query on Drupal.org and runs on every single page.
So it might be a good candidate for breaking out into either 1. an optional core module 2. a contributed module.
This would remove both the confusion and the performance issue in one ;)
So a few questions. Does anyone actually use this? How much? Is there a contrib alternative already?
If we have to keep it in core for whatever reason, what would be a less confusing name for the menu item?