Here is what we are up to for Panopoly 1.8:

Already in

In progress, or very desirable

#2283531: Path alias isn't preserved if the user doesn't have "create url alias" permission
#2283223: Old content aliases should be preserved by default
#2239847: Update "persist" patch to pathauto
#2255095: Add "Crop" tool to Spotlight widget
#2202885: Install fails on BOA/Drush/Aegir - No migration found with machine name PanopolyDemoNode
#2183937: Error on install of Panopoly-based install profile: "Column 'module' cannot be null" when profile starts with "e"
#2190579: [META] We have no best practices for updating to new Panopoly releases
#2128959: Replace default "update" module behavior with something that makes sense for distributions
#2160731: Panopoly Magic should respect a view's configured view mode
#2217469: File and Image fields don't preview properly
#2115519: Undefined index: css in theme_panels_ajax_tab_ajax() (line 219 of panels_ajax_tab/panels_ajax_tab.module
#2231631: Tests randomly fail with "MySQL server has gone away" (take 4)
#2215829: .gitignore file interferes with adding and committing rebuilds of the full Drupal codebase
#2063541: Remove Open Sans?
#2229297: Update 'media_vimeo' to version 2.0
#2209441: Update respondjs to version 1.3
#2159149: 'file_display' components are always overridden (update Media / File Entity)

Nice to have

#2186551: Include role_export in Panopoly
#1987386: Include Radix theme in Panopoly
#2166865: Removing non-required modules from .info / .make files
#2181079: Update to Navbar 1.7
#1965864: Support CKEditor in Panopoly
#2144021: Panopoly Magic only provides node view modes for view mode selection

Comments

dsnopek’s picture

Title: Panopoly 1.5 hitlist » Panopoly 1.6 hitlist

Panopoly 1.5 is going to be a security release for #2254999: Update FAPE to version 1.2 for SA-CONTRIB-2014-048

So, I'm just going to make this hitlist/issue be about Panopoly 1.6.

dsnopek’s picture

Issue summary: View changes
lsolesen’s picture

Issue summary: View changes
dsnopek’s picture

Issue summary: View changes
dsnopek’s picture

Title: Panopoly 1.6 hitlist » Panopoly 1.7 hitlist

Panopoly 1.6 became a simple security release - updating the version on this hitlist to 1.7.

cbiggins’s picture

Can we add an updated file_entity? I'm being bitten by #2267483: Remove user ID in download token generation and allow file download URLs to work across all users atm.

Thanks btw, love this distro to death.

dsnopek’s picture

@cbiggins: The goal is to update Media and File Entity in this issue which is already on the hitlist: #2159149: 'file_display' components are always overridden (update Media / File Entity). Unfortunately, there were a number of problems with the latest Media the last time I tried it. It might be worth making a new issue to update just File Entity passed the revision to fix that bug (assuming it'll work with our current version of Media).

cosmicdreams’s picture

Issue summary: View changes
dsnopek’s picture

Issue summary: View changes
dsnopek’s picture

Issue summary: View changes
dsnopek’s picture

Title: Panopoly 1.7 hitlist » Panopoly 1.8 hitlist
Issue summary: View changes
Status: Active » Closed (fixed)

Due to some issues with the Drupal.org packager, this became the 1.8 release:

#2306225: Packaging error with Panopoly 1.7 release: Unable to download tinymce

Now that that's out, we have the new 1.9 hitlist here:

#2309809: Panopoly 1.12 hitlist

miromarchi’s picture

Hi and thanks as always for the great job!
I've found a minor issue upgrading to panopoly 1.8 in transliteration module related update 7100 (panopoly_core), and I commented with an extensive log in issue: Add transliteration https://www.drupal.org/node/2213769#comment-9002913.
Thanks