From InstallStorage::getAllFolders() is a misleading method name:.
getAllFolders() is a very confusing method name, assumed that it returns folders, but it returns an array keyed by configuration files with the folder as value.
Rename the method.
- Choose a new name.
- Rename the method in
InstallStorageand its child classes. (Novice task)
InstallStorage::getAllFolders() is renamed. (This method is protected; therefore, this is not a public API change and does not need a change record.)
Original report by @alexpott
Over in@berdir remarked that getFolders is poorly named. I agree.