Release notes

Important:

#2102211: Default to the latest version of jQuery changed the default version from 1.5 to the latest available jQuery version, in the case of 7.x-2.4: 1.10.

If your site has never set the jquery_update_jquery_version variable, it will now default to the latest jQuery version available.

If any modules break because of this update, you should open an issue with the relevant module so it can update it's code to support newer versions of jQuery. jQuery Update has always allowed a site to choose which jQuery version is appropriate for that particular site (ie: what works with other installed libraries). Opening issue and declaring that jQuery Update has broke your site will be "Closed (works as designed)".

To mitigate the pain of upgrading and waiting for the affected module(s) to fix their code, you can temporarily set the version being used back to 1.5.x in /admin/config/development/jquery_update, or by adding the following to your settings.php file:

<?php
$conf
['jquery_update_jquery_version'] = '1.5';
?>

 

Changes since 7.x-2.3:

* Issue #1448490: Remove the states.js overwrite as it was fixed upstream by RobLoach, ezheidtmann, ethanhinson, nagy.balint, spiderman | ericduran: Remove the states.js overwrite as it was fixed upstream. |
* Issue #1909834: Not Deleting all variables when uninstalling module by mokitger: Not Deleting all variables when uninstalling module. |
* Issue #2023789: Offer latest jQuery 1.10.x as an option (currently 1.10.2). by ericduran: Added Offer latest jQuery 1.10.x as an option (currently 1.10.2). |
* Updating default version to 1.9 |
* Issue #1901672: Offer latest jQuery 1.9.x as an option (currently 1.9.1). by mikeytown2, -enzo-, ericduran, muka: Added Offer latest jQuery 1.9.x as an option (currently 1.9.1). |
* Issue #1801388: When a CDN is used, the jQuery UI Effects library never gets added unless the jQuery UI core library is added also by David_Rothstein: Fixed When a CDN is used, the jQuery UI Effects library never gets added unless the jQuery UI core library is added also. |
* Issue #2040991: jquery.effects.core.min.js is missing in the dev version by peterpoe | SocialNicheGuru: Fixed jquery.effects.core.min.js is missing in the dev version. |
* Issue #1959740: Missing ui.menu CSS and JS over at jquery_update_jqueryui_replace by Punk_UnDeaD, emattias: Fixed Missing ui.menu CSS and JS over at jquery_update_jqueryui_replace(). |
* Issue #2107637: Coding Standard Fixes by ericduran: Coding Standard Fixes. |
* Issue #2102211: Default to the latest version of jQuery by RobLoach: Default to the latest version of jQuery. |
* Issue #1448490: Remove the states.js overwrite as it was fixed upstream by RobLoach, spiderman, nagy.balint, ethanhinson | ericduran: Fixed states.js upstream and remove the overwrite in jQuery Update. |
* Issue #1974974: Adding ui.tooltip by ericduran: Adding ui.tooltip. |
* Issue #1954930: Loads the frontend version on ajax calls on backend pages by lucascaro, ericduran: Fixed Loads the frontend version on ajax calls on backend pages. |
* Issue #1956766: incorrect hook name in function docblock by ericduran, joachim: Fixed incorrect hook name in function docblock. |
* Issue #1953774: jquery UI 1.10.2 does not work with jquery 1.5 by OnkelTem: Fixed jquery UI 1.10.2 does not work with jquery 1.5. |
* Issue #1947438: Update jQuery UI to the latest version (1.10.2) by ericduran: Fixed Update jQuery UI to the latest version (1.10.2). |
* Issue #1524944: Allow different version for administrative pages by muka, Cottser, paskainos, ericduran, realityloop, hswong3i, DamienMcKenna, eromba, mikeytown2, Jacine: Added Allow different version for administrative pages. |

Download Size md5 hash
jquery_update-7.x-2.4.tar.gz 1.14 MB 9cc4f8b964202f1d6f005a43a08060c6
jquery_update-7.x-2.4.zip 1.33 MB 1ce9cf9593af10d447a894907eb74e8a
Last updated: April 2, 2014 - 23:44
View change notices for this release
Official release from tag: 
7.x-2.4