1.10.4 is out:

http://code.jquery.com/ui/1.10.4/jquery-ui.js
http://code.jquery.com/ui/1.10.4/jquery-ui.min.js

PS: Also the project's page still says:

Drupal 7 to jQuery 1.5.1/1.7.1/1.8.2, 1.9.1, 1.10.2 and jQuery UI 1.10.1 (in dev branch 7.x-2.x-dev)

...we need to update that anyways because the version we ship dev with is 1.10.2 (#1947438: Update jQuery UI to the latest version (1.10.2)), but once we get 1.10.4 in (this issue here) we should remember to re-update and generally remember to update it each time we update the version we ship with (including the /replace/ui/version.txt file).

PPS: PS: We also need a new "jQuery UI 1.10.x" component entry (#2048923: Create separate entries for each jQuery and jQuery UI version in the project's "Component" drop-down.) - we currently only have "jQuery 1.10.x".

Members fund testing for the Drupal project. Drupal Association Learn more

Comments

markcarver’s picture

Version: 7.x-2.x-dev » 7.x-3.x-dev
Parent issue: » #2852350: [jquery_update] 7.x-3.0 stable release
JurriaanRoelofs’s picture

Status: Active » Needs review

I was have some horrible edge case bug with my rgba color picker within views settings and updating jquery UI to 1.10.4 fixes it so I made a patch. I'll include the patch in my installation profile so it's not critical for me to get it in dev but of course that would be nice.

I know there are more modern versions of jQuery UI out today but I'm not knowledgeable enough about jQuery UI to say if those can be added in without breaking a whole bunch of stuff so I'm playing it safe for now with this 1.10 update.

JurriaanRoelofs’s picture

sumachaa’s picture

can we get this updated to the latest version: http://jqueryui.com/download/

jquery.ui.dialog version below 1.12.0 is vulnerable to XSS if the user input is allowed to pass through to the closeText property. Please refer vendor documentatation (https://github.com/jquery/api.jqueryui.com/issues/281)for latest security updates.

sumachaa’s picture

another issue which tracks latest version of UI: https://www.drupal.org/project/jquery_update/issues/2197249