I had ImageMagick (and ImageAPI) running quite happily on my OS X (Snow Leopard) workstation until I installed OS X 9 Mavericks. Since then, every time I try to configure ImageMagick in the admin page, I get this message:
user error: ImageMagick reported error code 5. Message: dyld: Library not loaded: /usr/local/lib/libltdl.7.dylib Referenced from: /usr/local/Cellar/imagemagick/6.8.7-0/bin/convert Reason: Incompatible library version: convert requires version 11.0.0 or later, but libltdl.7.dylib provides version 9.0.0 in /Users/joelguesclin/Sites/de/sites/all/modules/imageapi/imageapi_imagemagick.module on line 235.
I have done everything thing I can think of. Uninstalled ImageMagick and reinstalled it (using brew not MacPorts), did the same for libtools...
Now I am in a situation where ImageMagick seems to work ok when run from the command line on the workstation, but still gives me this same error message from Drupal.
When I execute the "Version" command I get this, which looks fine:

imac:Sites joelguesclin$ /usr/local/Cellar/imagemagick/6.8.7-0/bin/convert -version
Version: ImageMagick 6.8.7-0 2013-10-28 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2013 ImageMagick Studio LLC
Features: DPC
Delegates: bzlib freetype jng jpeg ltdl png png xml zlib

I can also do this, and it appears to work ok
/usr/local/Cellar/imagemagick/6.8.7-0/bin/convert pic.jpg pic.gif
So I can only conclude that the problem must be somewhere in ImageAPI... Help would be gratefully received