I am trying to get version 2.2 to work but am getting the following error on the admin/config/media/flexslider/add page.

Notice: Undefined index: version in _flexslider_validate_minimum_version_22() (line 550 of C:\Program Files\BitNami Drupal Stack\apps\drupal\htdocs\sites\all\modules\flexslider\flexslider.admin.inc).
To use Thumbnail Captions you must install FlexSlider version 2.2 or higher.
Notice: Undefined index: version in _flexslider_validate_minimum_version_22() (line 550 of C:\Program Files\BitNami Drupal Stack\apps\drupal\htdocs\sites\all\modules\flexslider\flexslider.admin.inc).
To use Display both thumbnail captions and normal captions you must install FlexSlider version 2.2 or higher.

I have tried this on three instances running Drupal 7.23

I have the following modules (among others) installed:

  • Chaos tools 7.x-1.3
  • FlexSlider 7.x-2.0-alpha3
  • FlexSlider Fields 7.x-2.0-alpha3
  • Views Slideshow 7.x-3.0
  • Views Slideshow: Cycle 7.x-3.0
  • Libraries 7.x-2.1
  • Views 7.x-3.7
  • Views UI 7.x-3.7

I have the following installed under /sites/all/libraries/:

  • FlexSlider
  • jquery.cycle

This is not allowing me to have the FlexSlider installed on the Drupal instances. Any help would be appreciated.

Files: 

Comments

minorOffense’s picture

On the reports page does it list the version of flexslider? Remember the name of the library folder has to be "flexslider" all lower case.

inversed’s picture

If the problem wasn't the FlexSlider library folder's name, you might have the issue I was having. Depending on where you download the FlexSlider "master" library, you may actually get version 2.1. That's what happened to me.

Check your FlexSlider JavaScript file (jquery.flexslider.js) to verify the version is correct (v2.2.0). I got the latest version from here: https://github.com/woothemes/FlexSlider/archive/master.zip

neha.drupal’s picture

Validation function shows the same error. Having the same issue.

minorOffense’s picture

Issue summary:View changes
Status:Active» Needs review

I've committed a fix to the validation function. If it fails to detect the version it shows a warning message that the version installed may not support all the options but should resolve any php notices.

Please try the latest dev (once d.o decides to publish one...) or get a copy from the repo directly.

Thanks!

aprilr’s picture

I'm also having this issue. I have recently installed/used this module on other sites, so don't understand why I am having it with this one. I have tried uninstalling and reinstalling the module. I have also tried updating the javascript file as mentioned above. I'm kinda dead in the water right now and sad. :-(

rdent4’s picture

aprilrayan, I solved the issue by using the link in #2, then extracting the file into sites/all/libraries and following the advice in #1 that the folder name in libraries must be exactly flexslider (all lower case and removing any other characters that might be there).

neo_iwokx’s picture

Thanks for this. ;) It worked.

jantoine’s picture

StatusFileSize
new6.55 KB
Test request sent.
[ View ]

Attached is a patch that greatly improves the version detection IMO. It clarifies that any FlexSlider library version within the 2.x branch is acceptable. It correctly reports the full version of the current installed library. It removes the storing of the version in a variable while also reducing maintenance by changing hook_library() to use data defined in hook_libraries_info().

  • Commit d09c0dd on 7.x-2.x, startslide by minorOffense:
    Updated README with proper download link
    Updated admin.inc to not throw...
DamienMcKenna’s picture

@minorOffense: Is this issue resolved now, or does it need further work?

searchweb’s picture

i also face same issue. I using drupal 7.28 and current drupal not have structure such as sites/all/libraries. It's install into modules/flexslider. So where should i put the

- jquery.flexslider-min.js
- flexslider.css
- jquery.flexslider.js

I have put into modules/flexslider/assests/js for .js file and modules/flexslider/assests/css for css files and still showing same error.

Any suggestion? I try the development version and it's showing error about libraries.

Newbie in drupal need help.

jantoine’s picture

@minorOffense,

I'm frustrated that you applied a "fix" without any community review while the patch contributed in #8 went ignored. I believe the patch in #8 greatly improves the version detection resolving many related issues. If you could provide feedback, I'd be happy to improve upon it so it can get committed.

minorOffense’s picture

Status:Needs review» Fixed

Added patch from #8

  • minorOffense committed 8c26f30 on 7.x-2.x authored by jantoine
    Issue #2118891 by jantoine: Error: "must install FlexSlider version 2.2...