I am having trouble posting content via the short form inside of groups. Valildation fails since the group audience fields are missing / not being posted.

"Please enter one more groups where this content will be posted."

Files: 
CommentFileSizeAuthor
#7 fix-typo-2115097-7.patch1023 bytesDevin Carlson

Comments

schackattack’s picture

Trying to set the appropriate value in the setting to group content fields, to determine whether they will be displayed on the mini node form of the browsing widget ("Display in the browsing widget mini-form") has no effect.

Devin Carlson’s picture

Status:Active» Fixed

I've been able to duplicate this by performing an update from Commons 3.3 and was able to fix this by clearing my browser cache. It looks like this is caused by cached JavaScript from 3.3 hiding the wrong fields in 3.4.

Marking as fixed but feel free to reopen this issue if it still persists after clearing the site cache and your browser's cache.

schackattack’s picture

Status:Fixed» Active

Thanks, but I'll reopen the issue. I cleared all caches right when I noticed. Problem's still there. I also updated from 3.3 by the way. I actually can't tell, if the problem was there with 3.3 version also, because I didn't get to posting any content from within a group before I updated.

Tim Clifford’s picture

having same issue - upgrading from 3.3

ezra-g’s picture

Component:User interface» Groups
Category:bug» support
Priority:Normal» Major

I was able to reproduce this problem as well by clearing my browser cache and doing a drush cc all on the site.

However, I discovered a typo that will likely cause problems when the Trusted Contacts module is enabled. In commons_groups_node_validate():

<?php
if (!module_exists('commons_truste_contacts')
?>

should read

<?php
if (!module_exists('commons_trusted_contacts')
?>
schackattack’s picture

Correcting the typo seems to have fixed it, thank you. I'm now able to post content from within a group.

Devin Carlson’s picture

Version:7.x-3.4» 7.x-3.x-dev
Category:support» bug
Status:Active» Needs review
StatusFileSize
new1023 bytes

A patch to make the change outlined in #5.

Devin Carlson’s picture

Status:Needs review» Fixed

Tested the simple typo correction in #7 by upgrading from Commons 3.3 and confirmed that it fixed the issue as mentioned in #6.

Committed #7 to Commons 7.x-3.x.

http://drupalcode.org/project/commons.git/commit/394acef

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.