• Advisory ID: DRUPAL-SA-CONTRIB-2013-074
  • Project: MediaFront (third-party module)
  • Version: 6.x, 7.x
  • Date: 2013-September-11
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


The MediaFront module provides a front-end media presentation layer for Drupal

The module doesn't sufficiently filter user input from MediaFront preset settings.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer mediafront" to exploit this bug.

CVE identifier(s) issued

  • CVE-2013-4380

Versions affected

  • MediaFront 6.x-1.x versions prior to 6.x-1.6.
  • MediaFront 7.x-1.x versions prior to 7.x-1.6.
  • MediaFront 7.x-2.x versions prior to 7.x-2.1.

Drupal core is not affected. If you do not use the contributed MediaFront module, there is nothing you need to do.


Install the latest version:

Also see the MediaFront project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.