Tried to install 'Commerce Kickstart' on XAMPP 1.8.2 several (4) times. Every time got the same error 'Call to undefined function field_attach_load()' after clicking button 'Save and Continue' on page 'Configure Site'. (see provided screenshot). Tried different names for the top level folder - no luck.

Have Drupal 6 and Drupal 7 running on the same Apache server with no issues.

I've seen someone reported this issue before and it was closed as non-reproducible.

Is there anything can be looked into? Any advice on possible cause? The download itself does not look corrupted.

Appreciate you help. Thanks.

error_screenshot.JPG99.92 KBAxNils


jsacksick’s picture

AxNils’s picture

Thanks for responding, jsacksick. Unfortunately nothing helped so far. I have tried a few thing in php.ini - no luck yet...

vasike’s picture

Category:bug» support
Priority:Critical» Normal
Status:Active» Needs review

it seems other people face the same issue and it's not strictly Commerce Kickstart related, but Drupal.

there are some other issues/posts about it.
maybe could help to fix yours.
- #481758-96: Fatal error: Call to undefined function field_attach_load() in includes/ on line 321 during install
- patch - #1525176-63: Using array_diff_assoc() for multilevel arrays in DrupalDefaultEntityController->cacheGet()

please let us know if and which it works.

lsolesen’s picture

Issue summary:View changes
Status:Needs review» Postponed (maintainer needs more info)

Did you solve this?

lsolesen’s picture

Status:Postponed (maintainer needs more info)» Closed (won't fix)

Closing for inactivity. Please reopen if still persists.