I am having two issues
1. I have a views slideshow and I started getting following error message. I had deleted one node with image field for the slideshow but don't know if that is the cause.

Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields() (line 245 of /home/domain/public_html/sites/all/modules/views_slideshow/theme/views_slideshow.theme.inc).
Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields() (line 245 of /home/domain/public_html/sites/all/modules/views_slideshow/theme/views_slideshow.theme.inc).
Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields() (line 245 of /home/domain/public_html/sites/all/modules/views_slideshow/theme/views_slideshow.theme.inc).
Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields() (line 245 of /home/domain/public_html/sites/all/modules/views_slideshow/theme/views_slideshow.theme.inc).
Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields() (line 245 of /home/domain/public_html/sites/all/modules/views_slideshow/theme/views_slideshow.theme.inc).

2. I have superfish menu and views slideshow. The superfish menu is overlapping with the slideshow. Don't know which module have the problem. Here is the site.

Comments

Net Mystic’s picture

I was having the same problem for awhile. After spending a whole day trying to debug this, I finally realized that I had used the Field Permissions module to limit viewing of the slideshow fields to certain roles (with the intention of preventing unauthorized users from editing slideshow fields in the node edit form). Once I turned on the "View anyone's value for field Slide Image" permission for all roles, the slideshow works fine!

If you've activated the Field Permissions module, this may be your solution! Hope this helps!

~ Net Mystic

dwaine’s picture

My dblog was also filling with these notices:
Notice: Undefined index: field_slide_image_1 in _views_slideshow_preprocess_views_slideshow_pager_fields()
The Drupal environment contained neither Superfish nor Field Permissions modules.

I cannot comment on the root cause of the notices but did find a resolution.

From the 'edit view' page I editted the 'Settings' adjacent to 'Format: Slideshow'. Inside the section 'Bottom Widgets' the 'pager type' was set to 'fields'. This is the correct setting for my view. I changed it to the other option 'jCarousel Pager' and clicked the 'Apply' button. I immediately retraced that path and then changed the 'pager type' back to 'fields' and clicked 'Apply' again. After saving the view the notices stopped appearing.

I verified this single change resolved the issue by repeating the process against my project's development environment.

dwaine’s picture

Issue summary:View changes

uninstalled everything related to views slideshow and reinstalled. error message gone. have not tried creating slideshow again.