I had some troubles getting some client youtube videos to work with the video filter. This was my approach without reading the filters description:

The original video link was embedded in a blog, (e.g.: http://www.youtube.com/embed/S7_MsY2IJz4)

My first approach was to use the /embedd/XXX url with video filter. That didn't work.

So I clicked on the title within the embedded video, which leads to the site http://www.youtube.com/watch?feature=player_embedded&v=S7_MsY2IJz4. Then I used this link which didn't work either, because youtube prepends feature=player_embedded.

If there is a reason/policy why those url format's should not be supported, please let me know. Otherwise i've prepared a patch to allow the embed-syntax and some arguments before the v=-atttribute.


Nebel54’s picture

Status:Active» Needs review
new635 bytes
DamienMcKenna’s picture

Adding this to the proposed issue list for the 3.2 release.

DamienMcKenna’s picture

Closed another issue that covered (slightly) less functionality: #1400794: YouTube embeds not working properly when "featured" is in the query string

DamienMcKenna’s picture

Title:Allow more flexible Youtube Urls» Allow more flexible Youtube URLs
Status:Needs review» Reviewed & tested by the community

Good to go.

blackdog’s picture

Status:Reviewed & tested by the community» Fixed

  • blackdog committed 174354f on 7.x-3.x authored by Nebel54
    Issue #2030795 by Nebel54: Allow more flexible Youtube URLs

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.