I'm getting these errors on this page:

/admin/reports/google-analytics

  • Notice: Undefined property: stdClass::$rows in GAFeed->sanitizeReport() (line 383 of /.../sites/all/modules/google_analytics_reports/GAFeed.lib.inc).
  • Warning: Invalid argument supplied for foreach() in GAFeed->sanitizeReport() (line 385 of /.../sites/all/modules/google_analytics_reports/GAFeed.lib.inc).

Comments

deanflory’s picture

Issue summary:View changes

formatting

Rhodungeon’s picture

Same problem here, but only

  • Warning: Invalid argument supplied for foreach() in GAFeed->sanitizeReport() (line 385 of /.../sites/all/modules/google_analytics_reports/GAFeed.lib.inc).
mmenavas’s picture

I remember seeing similar warnings when I created a Google Analytics view and added some filters. Is this the case for you?

deanflory’s picture

I have not created a View that deals with Google Analytics.

Rhodungeon’s picture

Same for me

dsrikanth’s picture

I see the same.... Any clue?

FreeFox’s picture

Let me add my voice too :(

Warning: Invalid argument supplied for foreach() in GAFeed->sanitizeReport() (line 385 of /web/.../.../.../sites/all/modules/google_analytics_reports/GAFeed.lib.inc).

FreeFox’s picture

Issue summary:View changes

formatting

Plazik’s picture

The error has been occurred when there are not data in Google Analytics Data Export API.
The patch fixed it.

  • Plazik committed 77b4040 on 7.x-3.x
    Issue #2023745 by Plazik | deanflory: Fixed Notice: Undefined property:...
Plazik’s picture

Status:Needs review» Fixed
deanflory’s picture

Thanks Plazik!

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.