hook_filter_info() uses several callback functions.
We have a new standard for how to document callback functions:
The existing callback documentation for functions hook_filter_FILTER_* should be changed to use our new standard. For instance:
hook_filter_FILTER_tips() should be renamed to callback_filter_tips(), and it should be given
This needs to be changed in three places I know of:
- in the hook_filter_info() documentation block
- in the sample function body for hook_filter_info()
- in the function definition for hook_filter_FILTER_tips()
but we'll also need to see if it is referenced anywhere else in code.
Also, we should fix up any core implementations of hook_filter_info() so that their callback function documentation is changed to read "Implements callback_filter_tips()." instead of whatever it says now.
The same needs to happen for the other hook_filter_FILTER functions mentioned in the hook_filter_info() documentation.
This will take a little time, but it seems like a fairly straightforward project, so I'm marking it Novice.
It is a 7.x project only, since filters in 8.x use a class instead (at least I think so).
|PASSED: [[SimpleTest]]: [MySQL] 40,458 pass(es).|
|PASSED: [[SimpleTest]]: [MySQL] 40,362 pass(es).|
|PASSED: [[SimpleTest]]: [MySQL] 40,365 pass(es).|