http://responsiblerunners.org/
I'm in need of your help!
I've recently tried updating about 4 modules and now my site is down and I can't get back in. In Chrome, i'm seeing a white screen that says:

Fatal error: Call to undefined function entity_property_list_extract_type() in /home/responsi/public_html/sites/all/modules/entity/entity_token.tokens.inc on line 216

In Firefox, it says:

Site Under Maintainable. Fatal error: require_once() [function.require]: Failed opening required '/home/responsi/public_html/sites/all/modules/entity/includes/entity.controller.inc' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/responsi/public_html/includes/bootstrap.inc on line 3066

Has anyone come across this before? Any help would be much appreciated!

Thanks,
Dan.

Comments

alinouman’s picture

database?

danwheble’s picture

Thanks for your quick response. I backed up the site about 3 months ago but not sure about the database. I've already tried changing the "/public_html/includes/bootstrap.inc" file with the previous version but no luck.

Jaypan’s picture

This should be a good lesson for you to always take a backup of the database and file system before starting updates! And you should also test updates locally before doing them on your live system.

Anyways, to help you with your problem, you need to download the Entity API module and put it in your modules folder. That should solve the problem.

danwheble’s picture

Yes, unfortunately I've learnt that lesson the hard way. I'm definitely going to back everything up next time.

Jaypan, just to be sure: I need to download http://drupal.org/project/entity, unzip and put it in this folder: public_html/modules

Thanks so much for your help.

Jaypan’s picture

Yes, that should solve your problem, or at least your immediate problem. Let's see what happens next.

danwheble’s picture

Legend! I can now get back in. Immediate problem solved.

I see this warning when I log in:

Warning: require_once(/home/responsi/public_html/sites/all/modules/entity/includes/entity.controller.inc) [function.require-once]: failed to open stream: No such file or directory in _registry_check_code() (line 3066 of /home/responsi/public_html/includes/bootstrap.inc).

Do you know what file I now need?

Once again, thank you! You're helping me out big time.

Jaypan’s picture

That's just a left over error message from the issues you were facing. It should go away now.

danwheble’s picture

Fixed! I can't tell you how much of a relief that is. Thank you for your advice. Lesson leant: always back up.

Jaypan’s picture

Always! :)

Glad it got worked out.

muge’s picture

All I did was update Drupal 7 version from 7.31 to 7.32 this morning. Suddenly I had the error message
' Fatal error: require_once(): Failed opening required /modules/entity/includes/entity.controller.inc ...'
and my previous '/sites' folder did not have the Entity Api.

I have no idea how this discrepancy happened when the site was working fine before the update. After placing the Entity Api into sites/all/modules, all is working again now.

Thank you!