I'm trying to create a sub-theme using drush, with this command:
drush adaptivetheme "New Theme" New-theme

and this is what I get in return:
The drush command 'adaptivetheme New Theme New-theme' could not be found.

Comments

marcoka’s picture

Status:Active» Closed (duplicate)
StevenPatz’s picture

Status:Closed (duplicate)» Active

Except that I enabled the core AT theme and still drush does not create a sub-theme.

antonio_pantano’s picture

try to flush drupal cache with drush
drush cc all

then clear the drush cache
drush cc drush

Be sure AdaptiveCore is enabled

at this point:
drush adaptivetheme "My theme name" mythemename

StevenPatz’s picture

try to flush drupal cache with drush
drush cc all

Did that.

then clear the drush cache
drush cc drush

Did that.

Be sure AdaptiveCore is enabled

at this point:
drush adaptivetheme "My theme name" mythemename

see previous comment, AdaptiveCore is enabled.

antonio_pantano’s picture

Mhhh, is the hypen puntation mark allowed in the machine name?
Don't know, could you try to replace new-theme with new_theme if you used that.

Jeff Burnz’s picture

Version:7.x-3.1» 7.x-3.x-dev
Issue summary:View changes

Drush issues are all resolved in dev, the last one quite recently, apologies it took me so long to get around.

Jeff Burnz’s picture

Status:Active» Closed (fixed)