Hey folks,

Using Mailhandler in a profile, and I'm finding that it won't install because of the following line in the info file:
dependencies[] = system (>=7.8)

While this is documented in the info file creation guide, it seems that at install, version # isn't handled. See attached screenshot for error (Being run on Drupal 7.19) While this is likely a core bug, in the mean time, I'm attaching a patch that removes the requirement and adds a hook_requirements condition on install for the drupal version to be greater than or equal to 7.8. Patch below.


wbobeirne’s picture

Status:Active» Needs review
new1.15 KB
PASSED: [[SimpleTest]]: [MySQL] 183 pass(es).
[ View ]
Pancho’s picture

Hit this bug, too, when trying to install the first Alpha of Open Atrium 2.
Definitely looks like a core bug, so IMHO it should be rightaway filed and fixed there, not worked around here.

Pancho’s picture

Title:Info file requirement of >=7.8 doesn't work / breaks profile installs» Second-level versioned requirements breaks profile install
Project:Mailhandler» Panopoly
Version:7.x-2.x-dev» 7.x-1.x-dev
Component:Mailhandler» Install
new1.02 KB

Nope, this is no core bug. Core doesn't check any second-level requirements, see: #1253774: Dependencies of dependencies are ignored by installation profiles (and by test setUp methods).

Rather this is a Panopoly bug:
panopoly_core_install_load_profile() goes to some lengths filling the gap. While the required versions aren't processed, this is absolutely acceptable. However the version information needs to be stripped off the dependency string, otherwise the Drupal installer will be looking for a module called "system (>=7.8)" which is obviously wrong.

Enclosed patch should fix this correctly. Please test.

populist’s picture

Thanks so much for this patch. Reviewing now.

populist’s picture

Status:Needs review» Fixed

Looking good. Tested and committed to dev.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.