I have the Location and GMap modules working on our current Intranet. I am moving to Drupal Commons v3.1 at the end of the month. I have setup the organic groups with locative information so we can use the groups to represent all of our regions, districts, stores and corporate departments.

In Drupal Commons v3.1, the city/state/zip area displays like KS67205 Wichita, instead of Wichita, KS 67205. I have tried repositioning the locative fields and verified they are in the correct order. I thought it was just Drupal Commons, but I then realized it does not display properly on my other site. On my current site, it is displaying like:
9781 Magnolia Ave
92503 Riverside, CA
United State

Comments

podarok’s picture

Status:Active» Postponed (maintainer needs more info)

So, what is the question?

gr8britton’s picture

Sorry, I deleted the question when I was adding the new Commons Info and meant to add it.

Would like to see how to fix the order the fields are being displayed so it will be:

Address
City, ST/Provice Zip/Postal

Thanks!

gr8britton’s picture

Status:Postponed (maintainer needs more info)» Active
bdyerstewart’s picture

Same problem for me since upgrading to 7.x-3.0-alpha8.

Would like to see how to fix the order the fields are being displayed so it will be:

Address
City, ST/Provice Zip/Postal

Showing now:

5 Parker Point Road
04614 Blue Hill, ME

bdyerstewart’s picture

The address display is controlled by location.tpl.php in the location module's root. Make a copy and put it in your local theme's template directory and you can change it to display the way you want without tampering with source.
Find and move the following postal_code statement to below the state\province code:

gr8britton’s picture

bdyerstewart - Would you please provide the '...following postal_code statement...' info you referenced?

Nevermind. I figured it out and it works great. Thanks!

gr8britton’s picture

Issue summary:View changes

Deleted erroneous last line.