I get this when trying to edit an existing node with a populated entity reference w/ an autocomplete widget:

Error message

InvalidArgumentException: Property revision_id is unknown. in Drupal\Core\Entity\Field\Type\EntityReferenceItem->setValue() (line 84 of /Users/webchick/Sites/8.x/core/lib/Drupal/Core/Entity/Field/Type/EntityReferenceItem.php).
The website has encountered an error. Please try again later.

This is the very definition of "Needs tests" :P

Files: 
CommentFileSizeAuthor
#5 entity-reference-ng-1956434-4.patch10.98 KBBerdir
PASSED: [[SimpleTest]]: [MySQL] 53,656 pass(es). View
#5 entity-reference-ng-1956434-4-test-only.patch5.52 KBBerdir
FAILED: [[SimpleTest]]: [MySQL] 53,733 pass(es), 0 fail(s), and 1 exception(s). View

Comments

ParisLiakos’s picture

Fix is already in #1847596: Remove Taxonomy term reference field in favor of Entity reference, not sure if we should wait for that to get in though

webchick’s picture

I would say not... last I checked there were some pretty hefty UX concerns with that patch, and this is just a straight-up bug.

xjm’s picture

Yeah, let's definitely pull that fix out of that patch and file it separately here with its own test coverage.

amateescu’s picture

Assigned: Unassigned » amateescu
Berdir’s picture

Assigned: amateescu » Unassigned
Status: Active » Needs review
Issue tags: -Needs tests
FileSize
5.52 KB
FAILED: [[SimpleTest]]: [MySQL] 53,733 pass(es), 0 fail(s), and 1 exception(s). View
10.98 KB
PASSED: [[SimpleTest]]: [MySQL] 53,656 pass(es). View

This should be the relevant pieces from that issue.

Berdir’s picture

@amateescu: I hope you didn't already start :)

amateescu’s picture

Status: Needs review » Reviewed & tested by the community

I did, but my patch is *identical* to yours, so we're good to go here.

Status: Reviewed & tested by the community » Needs work

The last submitted patch, entity-reference-ng-1956434-4-test-only.patch, failed testing.

xjm’s picture

Status: Needs work » Needs review

#5: entity-reference-ng-1956434-4.patch queued for re-testing.

Berdir’s picture

Status: Needs review » Reviewed & tested by the community

#5 passed now (I assume that was a testbot problem), so back to RTBC.

webchick’s picture

Status: Reviewed & tested by the community » Fixed

Awesome, thanks folks!

Committed and pushed to 8.x.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.